cancel
Showing results for 
Search instead for 
Did you mean: 

New BIOS for Z390 and RTX 4090 Black screen fix

kayawish24
Level 10
Hello, i am using 9900KS with Asus stirx Hero Z390.I bought Asus strix 4090 OC but the problem is when my PC is in idle mode likle if i am browsing or watching youtube screen will start going black with Nvidia drivers crashing.I am on Nvidia newset drivers which was released 2 days ago.I am getting this problem since november with my RTX 4090.But when i am gaming then i dont encounter any crash etc.Now i am using prefer max perfonce in nvidia control panal and all is stable till now.I saw that asus released mainboard driver specialy on Z790 board for RTX 4090 Fix and many people with Z790 problems were solved with that.I want to ask asus to release BIOS for Z390 board too otherwise i will be forced to RMA my card which i dont want.Before 4090 i was using 3090 Ti and not a single crash i got in idle.looks like the card undervolt too much in idle mode so it stops giving signal to display port.even viewer is full of nvlddmkm errors.when i do prefer maximum performance in nvidia control panal then i dont get black screen in idle.
5,009 Views
14 REPLIES 14

My new build started doing this randomly after some time ... now I am getting  black screens + fans revving up daily which is really frustrating. This can happen whether I am ingame or just browsing.

I have done the following to try and debug:

  • I have updated to the 2.1 vbios
  • Set my gpu power to maximum performance. 
  • Removed the Phanteks PCIE 4.0 vert bracket
  • Reduced the power draw in Afterburner to 85%
  • All still have resulted in a black screen at some point.

The last thing i haven't tested is the Cablemod cable. 

Will let you know if I find anything or solution here.

Jiaszzz_ROG
Customer Service Agent

Hello, @Wayâ__ 

May I ask if you are encountering the situation that the screen will gradually go black and the Nvidia driver will crash when idle?
How often does the problem occur, and what is the context in which it occurs?
Please try to update the graphics card driver, clear the CMOS, and reboot. Update the BIOS version if needed.
If the problem persists after completion, please provide the following information so that we can better understand your situation:
- the model name of your motherboard
- the current BIOS version and the content of the setting in BIOS (or whether it is the default)
- the serial numbers of your motherboard and GPU via pm
- the brand and model name of the CPU, DRAM, GPU, and PSU currently installed
- the OS version and OS build
- display/fan-related settings, and screenshots of the settings

Thank you.

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌ 🙂

Hi Jias,

I will try and answer all questions inline as best I can ^^

May I ask if you are encountering the situation that the screen will gradually go black and the Nvidia driver will crash when idle?

The screen will instantly go black and the GPU fans will blow at 100% until i hard reset / power down.

How often does the problem occur, and what is the context in which it occurs?

Sometimes not for days ... other times  2 - 3 times a day. It varies, I could be browsing the internet or when I play a game. It doesn't appear to be related to GPU load.


Please try to update the graphics card driver, clear the CMOS, and reboot. Update the BIOS version if needed.

One step ahead of you with the graphics driver and BIOS update. I am running default settings witth only EXPO ( Tuned ) Profile.


If the problem persists after completion, please provide the following information so that we can better understand your situation:
- the model name of your motherboard - ASUS Crossahair VIII X670E Extreme 
- the current BIOS version and the content of the setting in BIOS (or whether it is the default)  Default BIOS Settings with only EXPO ( Tuned ) I belive it's the 1003 BIOS.
- the serial numbers of your motherboard and GPU via pm  I an send this later this evening 
- the brand and model name of the CPU, DRAM, GPU, and PSU currently installed AMD Ryzen 9 7950X , 64GB ( 4 x 16 ) G.Skill  Trident Z NEO DDR5 5600 C28 ( F5-5600J2834F16GX2-TZ5NR  ) , ASUS RTX 4090 Gaming OC, Corsair AX1600i, Cablemod 12vHPR Custom connector
- the OS version and OS build Windows 11 - up to date with the latest updates installed 
- display/fan-related settings, and screenshots of the settings Dell Alienware AW3821DW 3840x1600 @ 144Hz Gsync , Default fan profile for GPU

I am still testing some things as it;s quite random. But will advise on the recommendations above.

 

 

Jiaszzz_ROG
Customer Service Agent

Hello, @Wayâ__ .

According to the ROG CROSSHAIR X670E EXTREME official website, the latest BIOS version is version 1101, released on April 11, 2023. Please update to the latest version before confirming the problem.
At the same time, since your current memory card is not listed in the QVL list of the motherboard, it is recommended that you use the memory cross test in the QVL list and start the test with a module that should be installed in the DIMM_A2 slot.

Thank you.

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌ 🙂

Thank you for the reply.  I find it strange that the memory is not in the QVL as I searched on the G.Skill site for compatible memory using their RAM Configurator and this kit comes recommended there ><

I have been on 1101 for the last week or so...  I haven't had any issues f so I am hoping the BIOS update along with ensuring all power connectors are properly in would solve the  issue. I will keep this post updated on any developments there.

Thank you again.