cancel
Showing results for 
Search instead for 
Did you mean: 

My ThunderboltEX 4 wont detect my Thunderbolt device

cernes
Level 7

Hello, just bought a brand new Soundboard (UAD Apollo x8) and trying to use it on my PC Windows 11 64 bit.

This soundcard is only working with Thunderbolt connection (TB3) and my motherboard is a Tuf Gaming B550 Plus and has a Thunderbolt header on it.
So i just bought the Asus ThunderboltEX 4 and plugged it on the PCIe_16 running on X4 but my Soundboard won't be detected on the computer.
I tried to plug my phone on the ThunderboltEX 4 and my phone is charging so i assume the card is well connected and works fine.

Here you can see that on the Thunderbolt Control Center, it shows me that the ThunderboltEX 4 is detected.IMG_20231124_174314.jpg
I've tried lot of things but nothing seems to work for now, i know that multiple people managed to get it work so i really need some help since i don't know what to do right now.

Here what i tried and some informations on the build : 

Windows 11 64bit (last update)

Motherboard : Asus TUF GAMING B550-PLUS

CPU : Ryzen 5 5600X

GPU : AMD RADEON RX 6700

 

I updated the BIOS to the newest version 3404

I put the Thunderbolt support on Enabled into the BIOS

I downloaded the latest AMD chipsets, Intel Thunderbolt driver

I tried to update the firmware for the ThunderboltEX 4, but i assume NVM 36.0 is the latest since nothing changed

 

I am using a brand new Thunderbolt 4 cable and i tried it with my phone on the EX 4, works fine since my phone started charging.

I of course downloaded the latest drivers from my Soundboard

I assume my computer should at least detect my Soundboard when i plug it in, but nothing happens at all when i plug it, and nothing appears into the Thunderbolt Center Service

From now, i really don't know what to do and i really need some help.

Feel free to ask me any informations on the build/drivers and i will provide them

Thank you 😥

679 Views
7 REPLIES 7

cernes
Level 7

Up 😥

Jiaszzz_ROG
Customer Service Agent

Hello, @cernes 

Although ThunderboltEX 4 supports Thunderbolt 4, while the Apollo x8 utilizes Thunderbolt 3, the port should be backward compatible with connected devices.
According to your description, the TUF GAMING B550-PLUS is able to recognize the ThunderboltEX 4 but fails to identify the Apollo x8 device.
If you have confirmed that ThunderboltEX 4 is installed in the PCIe 3.0 X16 slot on the TUF GAMING B550-PLUS, all relevant drivers and firmware are up to date, and the Apollo x8 is correctly connected as per the instructions, yet the configuration remains unsuccessful, we recommend cross-testing with other Thunderbolt devices that connect to the motherboard to further address potential issues.

Thank you.

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌ 🙂

Hello ! 

Thank you for your answer.

Unfortunately, i don't have any other Thunderbolt device to test it. 

I know for facts tho that people are using Apollo x8 through ThunderboltEX4.

Did you ever figure this out? I'm using the UA Apollo Twin (thunderbolt 2) which I've tried both through a Thunderbolt 4 hub as well as straight into the Thunderboltex 4, and it's also not being detected. I confirmed that it is detected on my M1 laptop, so this has to be an issue with ASUS drivers somewhere down the line. I've also confirmed that all my drivers are latest, thunderbolt card is detected, but no dice on the UA. Even my CaliDigit Thunderbolt dock doesn't show up, tested with two different Thunderbolt 4 cables. I've pretty much gone through all the steps you have, so I'm at a lost at this point, and if it's happening with several others, you'd think ASUS would take more action. I've even got the exact same motherboard, and also running W11.

Hello, i finally solved the problem for me.

As weird as it sounds, i had to plug every cables that are on the ThunderboltEX4 (USB C, DISPLAY PORT, SUPPLY) even if i'm not using them. 

When i did that, the Apollo was being detected into Thunderbolt Center Service but my Apollo wasn't still working.

i finally had to go into the BIOS to change the Chipset host to Maple Ridge and now it is working well.

Hope it will help you.

Where do you find this setting in the BIOS? I tried searching it but no luck 

You should have a research option somewhere in the BIOS, just try to type "THUNDERBOLT" into the research thing