cancel
Showing results for 
Search instead for 
Did you mean: 

My new ROG Strix Motherboard not Powering on

KUSHRICKS0225
Level 7

Hello,

I recently got a new MoBO Asus ROG STRIX B550 XE. I have plugged in all connectors and the ROG logo lights up but nothing happens when I click the Power Button, no fan, no CPU nothing. 

The power Supply I am using: SAMA 80Plus Gold 750W Power Supply Full Voltage Full Modular

Motherboard: ASUS ROG Strix AMD AM4 ATX Motherboard B550 XE WIFI 6

Case: MUSETEX ATX PC Case, / MSI MPG GUNGNIR 110R (Neither Works) 

I have tried many things, swapped the MoBO, Swapped the Case, tried using an old PSU, no luck. 

Please help.

 

215 Views
1 REPLY 1

Jiaszzz_ROG
Customer Service Agent

Hello, @KUSHRICKS0225 

May I ask if you have referred to the ROG STRIX B550-XE GAMING WIFI User’s Manual to ensure all hardware, including CPU, RAM, and PSU, is installed correctly?
When experiencing booting issues, are there any Q-LED indicator lights on or any Q-Codes displayed?
If so, please refer to the corresponding explanations in the two FAQs provided for troubleshooting:
[Motherboard] ASUS motherboard troubleshooting via Q-LED indicators
[Motherboard] Common Q-CODE(Error CODE) and Troubleshooting
Please also refer to [Motherboard] Troubleshooting - No Power/No Boot/No Display and test with minimal components to isolate the possible cause.
Additionally, if you haven't updated to the latest BIOS version 3405 yet, consider updating and then clearing CMOS before checking again.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂