cancel
Showing results for 
Search instead for 
Did you mean: 

I've been forsaken by the PC gods and need some help figuring this out.

Necronar
Level 7

So, I'll start by saying that I've been building PCs for a long time, so I'm not new to this and can follow along. I'm having a hell of a time trying to figure out what's going on here and could use any assistance in trying to troubleshoot what my problem here is. Here's the scenario:

Initially, I had a problem with my new system (not relevant here...but it turned out to be an ASUS MB problem and is sent in for RMA). However, I used my old Ryzen 3900X system to just play some games and get some 3D rendering done. Put it all together, it all worked fine for a day. Then at night, while I was playing some games it just shut off. Every time I tried turning it back on, it would boot up for a second and then shut off again (literally a second). I tried out some things and eventually came to the conclusion that I'd change the CMOS battery. The system tried booting up, but then I got a Q-Code 04 Error and the DRAM light is on. Tried moving around the modules to different slots; tried one at a time...no luck.

I've tried clearing the BIOS (swapping out the CMOS battery should have already done that, though). And had no luck there. I updated the BIOS from the ASUS flashback port, though nothing in the build had changed from when it was previously running.

After reading up on some threads, some people suggested swapping out the PSU, as that worked for them. So, I bought a new PSU (1200W, which is the same wattage I had been using previously). That worked! I got it to boot into Windows and logged in after the BIOS had finished updating once it could post. I went to go grab a drink from the fridge and it was on a restart loop. I reset and when it booted up again, I got a Q-Code 04 Error and the DRAM light was on. I tried swapping out to a new CMOS battery, just in case the one I installed was bad, and no lucky there.

So, does anyone have any clue what could be happening here? What am I missing? Is it really the RAM? Why would it boot once into Windows after swapping out the PSU but stop working again? I'm desperate for any suggestions here.

Here are the specs:

AMD Ryzen 9 3900X
Arctic Liquid Freeze II 360 AIO
ASUS ROG Crosshair VIII Hero Motherboard
ASUS TUF Gaming OC 4090 RTX
32GB Corsair Vengeance LPX DDR4-3600
PSU (First one I tried): Corsair RM1200 (1200W)
Psu (Second one): Thermaltake Toughpower GF A3 (1200W)

Going from RMAing one motherboard, to now having trouble with another system is driving me mad and I feel like nothing is working for me. I've been doing this stuff since the early 90s and this is the worst I've had to deal with.

Any help would be appreciated.

233 Views
6 REPLIES 6

Bogus5
Level 12

OK, but why do you think the RAM modules are in working order, maybe one is indeed faulty. They may also have dirty contacts.

I've cleaned them and the slots. If they were the problem, would it really boot again after changing out the power supply and no other time? I'll try cleaning them again. I ran them in the machine for an entire day, doing all kinds of tasks before it shut down abruptly. Could both modules go bad at the same time?

Jiaszzz_ROG
Customer Service Agent

Hello, @Necronar 

Could you please confirm the current BIOS version, and is the RAM VENGEANCE® LPX 32GB (2 x 16GB) DDR4 DRAM 3600MHz C18 Memory Kit - Black as the part number is CMK32GX4M2D3600C18, you installed?
If so, the RAM is not listed in the QVL for the ROG Crosshair VIII Hero.
We suggest cross-testing with the memory listed in the QVL, and please refer to [Motherboard] How to query (CPU/memory) QVL List? if needed.
It's also recommended to install the memory in the DIMM_A2 and B2 slots as per the user manual.


Meanwhile, I have DMed you, kindly check at the inbox on top right corner. 

Thank you.

I can't confirm the BIOS as I'm not able to POST, but I used the flashback port on the back i/o to update successfully to 4702. I know this worked because I got it to boot once afterwards and it updated it, then booted into Windows and then it went into an endless loop of restarting. Once I turned off the system and powered back on, I went right back to an Q-Code 04 error.

The RAM was definitely on the list. I had this system up and running for 3 years without a single problem. It's the CMK32GX4M2K3600C16 ver4.31 and it's on this list. However, it's not longer on the latest list for the 3000 series. But it definitely was on the only list when I bought it, and still is listed in the document I linked above which is on the site.

Jiaszzz_ROG
Customer Service Agent

Hello, @Necronar 

Thank you for your prompt confirmation and for providing information via PM.
Based on your situation, we recommend cross-testing with different CPU and RAM configurations to isolate potential hardware issues.
If the problem persists and cannot be resolved, it may be advisable to arrange for repairs to conduct a thorough, comprehensive diagnostic and find any underlying problems.

Thank you.

Bogus5
Level 12

I've never heard of RAM modules failing en masse. Maybe one of them got a shot from his finger (?). Clean the slots too.