Showing results for 
Search instead for 
Did you mean: 

Fans RPM not showing in bios

Level 7

Hello, have ASUS PRIME Z690-P, firmware 2611.

Have connected AKASA SOHO 360 Dusk Edition to MB. Everything works fine.

Have a problem with another 3 fans in case. RGB works perfect, changing speed of fans works perfect but BIOS doesn't show me RPM.
Fans are connected to CHA1. Bios shows me 0 RPM.


Any idea what is wrong please? Thank you



Level 7

btw tried Armoury Crate, it's showing 0 RPM too for CHA1

Customer Service Agent

Hello @asmb 

In response to your description and the provided images, may I inquire if you have installed any additional fans aside from the water cooler?

Upon confirming PRIME Z690-P, the latest BIOS version is 2802, released on September 28, 2023, along with the corresponding Intel ME version, as opposed to the version 2611 and Intel ME version that you are currently using.

We recommend that you consider updating both the Intel ME and BIOS, followed by clearing the CMOS, and verifying if this could help to resolve the problem. 
Please refer to [Motherboard] Intel® Management Engine Firmware Update Instructions(ME) if needed.

Thank you.

Hello @Jiaszzz_ROG , yes I installed additional 3 fans AKASA. 2x TOP, 1x REAR. Connected to "Akasa splitter" and then to CHA1.

Didn't see there is newer bios firmware. Currently have 2611. Will upgrade BIOS and Intel ME now and then will give results here.


Hi @Jiaszzz_ROG , so I updated BIOS and intel ME, same result. But I found this:
- if I connect some FAN directly to CHA1, RPM works fine
- if I connect some FAN to CHA1 via AKASA splitter, RPM doesn't work

I don't need to use splitter, problem is fan's cables are short so I can't connect them to mb

Customer Service Agent

Hello, @asmb 

Based on the situation you've described, if you are encountering hardware limitations, such as length-causing connectivity constraints, we would recommend cross-testing with other extension cables. 

Thank you.