cancel
Showing results for 
Search instead for 
Did you mean: 

ECC ram speed

Toster256
Level 7

I'm trying to fight random reboots on my desktop / NAS based on:

CPU: 7950x3d, GPU: MSI Liquid RTX 4090, Motherboard: TUF X670E-Plus, PSU: RM1000x

Ram: 2x32GB DDR5 5600MT/s ECC Unbuffered DIMM CL46 2Rx8 (KSM56E46BD8KM-32HA)

I use virtualization, so Windows diagnostics is out of the picture, but when I play Alan Wake 2 in Windows VM I get random system restarts of the host system without any logs - just reboot with thermals not even close to red zone. So, clearly the problem is in hardware. I tried different PSU - Seasonic VERTEX PX-1000W with exactly the same symptoms, so power issues are out of the question as the system at peak consumes about 570W, so there is some room there. No overclocking, most of settings default, except for enabled ECC + IOMMU. So, I focused on the RAM as I see a few red flags there.

I did a bunch of tests and nailed it down to this simple sequence:

1. I started a clean tests - reset CMOS, default settings - run memtest86plus (no OS, bare metal) - works. reboot, mem test works again. Reported ram speed is 8.01GB/s

The bios says that even ram is DDR-5600MHz (target) - it works as DDR-5200MHz. That's completely understandable as 7950x3d memory controller is a limiting factor.

2. Default settings, set the ram speed to DDR-5200MHz - run memtest86plus - works, reboot, run again - I start getting a lot of memory errors. 8.01GB/s. Clearly, ram is at fault.

3. Default settings, set the ram speed to DDR-5000MHz - run memtest86plus - works, reboot, run again - lots of memory errors. 7.87GB/s. That's interesting, let's go down.

4. Default settings, set the ram speed to DDR-4800MHz - run memtest86plus - works, reboot, run again - memory errors. This is getting weird.

5. Default settings, set the ram speed to DDR-3600MHz - run memtest86plus - works, reboot, run again - memory errors yet again. 6.77GB/s. That's unbelievable. The ram was working fine without forcing the speed.

6. The motherboard clearly trying to get on the way and changes the memory timings to be unusable, so:

- I forced 46-45-45-90 primary timings which should be good for DDR-5600MHz while running on DDR-3600MHz(!). Memory errors(!)

- I loaded memory timings from Micron 5200MHz profile, DDR-3600MHz - memory errors.

It becomes apparent that any fixed ram speed is broken and produces memory errors.

7. Default settings, load Micron 5200MHz profile. Mem test passes, speed 8.27Gb/s(!).

8. Default settings, load Micron 5200MHz profile, memory speed DDR-5200MHz or DDR-5000MHz - errors, boot problems.

Bottom line.

So, it looks like Micron 5200MHz memory timings profile works, but any memory fixed memory speed is causes problems. I loaded 'Micron 5200MHz', enabled ECC, IOMMU, run Alan Wake 2 in VM Windows 11 and it looks like it more stable now(!). The system was crashing after a few minutes of play time, now it seem to work for at least 30 minutes and counting.

I was fighting the system instability for a few months now after I upgraded to the AM5 system and none of the suggested fixes worked and I tried a lot of them. But the problem seem to be in BIOS doing something weird with memory speed and timings. Thanks.

479 Views
7 REPLIES 7

Toster256
Level 7

I guess I talked too soon. Next day, my mostly idle system crashed with just bare use of GPU.

Jiaszzz_ROG
Customer Service Agent

Hello, @Toster256 

May I inquire about the current BIOS version you are using, and have you observed any changes when booting under default BIOS settings after a clear CMOS?
If you haven't updated to the latest BIOS version 1813, released on November 1, 2023, please consider updating and rechecking the issue.
Regarding memory, the "KSM56E46BD8KM-32HA" currently installed is not listed in the QVL for the TUF GAMING X670E-PLUS.


We recommend cross-testing with memory modules listed in the QVL and installing them in the DIMM_A2 and B2 slots as recommended in the user manual to ensure compatibility and stability.


Please refer to [Motherboard] How to query (CPU/memory) QVL List? if needed.

Thank you.

Updating to bios 1813 was the first action I did to mitigate this issue, without much success. I installed ram modules as described on the A2 and B2 slots.

The board supports ECC ram, so I picked the module recent enough with good timings. The list contains only 2 ram modules and both of them has 4800MHz speed. The one I bought is newer with 5600MHz supported. I would expect it to be supported by the bios, but looks like it is not.

Toster256
Level 7

Oh, and all of the experiments I did was after clear cmos and using default settings except for the settings mentioned in the post if it wasn't clear. Using faster ECC ram I would expect it to work at least at default 4800MHz with conservative timings, but it looks like after a subsequent reboot something happens in bios which renders the system completely unusable, see the original post.

Toster256
Level 7

Something is terrible broken if with factory settings lowering the ram speed to 4800MHz causes the system to boot loop.

Jiaszzz_ROG
Customer Service Agent

Hello, @Toster256 

We would recommend cross-testing the memory modules listed in the QVL to ensure compatibility and stability.

Thank you.

Thank you. I don't have the ability to test other ECC modules at this point. What I found out is that 'Memory Context Restore' is not working correctly it seems. If I leave it in auto for my ram module and set any ram speed the first boost is fine, but next one causing crash loop. If I change Memory Context Restore to Disabled I don't have this problem. I can set memory speed as well as ram timings and voltages without issues and I can reboot. So, this looks like a firmware bug to me, but I have found a workaround for it even if I have to wait an extra minute every boot.