cancel
Showing results for 
Search instead for 
Did you mean: 

Crosshair VIII Formula - Marvell Aquantia AQC111C Firmware Update

AuxNuke
Level 7
I'm having an issue where the 5G LAN port (AQC111C ) disconnects for a bit (can't ping any device on the LAN) and then reconnects after anywhere from a few seconds to a minute or so. When this happens, no other wired device on my LAN experiences this issue. After some research is seems like a firmware update helps to resolve or reduce this issue.

Notes:
- I'm using CAT7 cable directly into a Netgear multi-gig switch with the latest firmware; this shows a full 5GbE connection with great speeds when working.
- I'm running the latest driver available directly from Marvell, version 3.1.6.0
- Current AQC111 firmware version is 3.1.81, the latest is 9 revisions newer at version 3.1.121
- The issue does not happen when using the Intel 1GbE NIC

The latest AQC111 firmware, 3.1.121, is available direct from Marvell but the update tool says "Not Available" when running from a CMD prompt as Admin.

There is an XML file included in the package named updatedata.xml that seems to restrict the use of the FW update tool to known hardware ID's. I added a line for the correct hardware ID of my device in the section that notates the AQC111.clx firmware file:


The firmware update tool now says "Incompatible Driver"
"Found incompatible Aquantia AQtion driver version (3.1.6.0) on one or more adapters.
To enable firmware update for these adapters, please, update driver to version 2.x.x.x."

Anyone know a way around this? Asus should really just include the damn FW update on their support site....
1,591 Views
7 REPLIES 7

VanDisaster
Level 7
I was upgrading my 10G nic ( also Aquantia ) some time back & accidentally flashed the 5G onboard card first - which is now invisble to an OS completely ( even if I pull the 10G card out, yes ). So, if you manage this successfully, please let us know! I also would like the onboard specific firmware - I did appeal for it in the past too.

Got the same board Crosshair VIII Formula.
I also tried to Update the Firmware of the AQC111C with the correct line, but I still get the Error "No adapters can be updated".

My issue is that after a Reboot the Aquantia Lan Adapter stops working and isn't showing up in Windows.
When I Boot into BIOS, disable and enable the Adapter, it works till the next reboot and then stops again.

It's turning me really mad. I read somewhere online, that it has Problems with PCI Gen4 Devices and I run 2x nVME.
Usually everything is set to Auto, but even if I turn it to GEN3, it still doesnt work, till I disable/enable the Lan Adapter again.

It really is driving me crazy and I tried it with older and newer BIOS, currently running 4201 Beta.

Probably a Software Problem and I think it has something to do with the Firmware, but cant even Upgrade the Thing. 😞

Edit
Finally got the Firmware Update running. Needed to add under the value .

You need to have the newest Driver installed, after you can do the Upgrade and it runs trough. For me it did Brick the Adapter and still after a Restart I need to go to BIOS to disable/enable it. Really Annoying and will contact the ASUS Support. Dont recommend to Update the Firmware yet its somehow broken.

nataku
Level 7
Has anyone been able to update? I've been having issues with this port ever since I bought this motherboard.

Same problem here on the ASUS ROG Crosshair VIII Formula with the latest bios "Version 4201". Aquantia interface randomly fails to power up in Ubuntu 22.04 and Windows 11. Sometimes it works, sometimes it doesn't. Something must be done about this. Give us something ASUS.

I have the exact same issue and could only get the card working at half of the speed, 2.5GB, by manually setting the link speed to 2.5GB full duplex. Anything higher than that, the connection is lost. I tested this problem on freshly installed Windows 10 & 11 to confirm it's not Windows issue. Also driver version 2.2.2.0(comes with Windows) and the latest 3.1.3.0 from Asus site. Now I have an active ticket with them. will send this link to them in case no one here bothered to open case with them.

eisenb11
Level 8

Any update on this? I have the 3.1.7 drivers and the Marvell NIC still takes a while before it works after waking the PC from sleep. I'm also on the latest motherboard bios.