Showing results for 
Search instead for 
Did you mean: 

Cannot Install Windows 10/11 - A media driver

Level 8

Just put together a new PC with amd ryzen 7950x3d and ASUS x670-e gaming WiFi motherboard.

Created USB bootable using the windows media creation tool. The PC boots up to the USB drive and begins installing windows 11.

Immediately I get this media driver is missing error and I can’t get past.

Switched usb drive to different port as per suggestions; didn't make a difference. Put different types of drivers on my USB Stick and tried searching but none of the drivers was what its looking for. 

This motherboard doesn’t have any USB 2 ports, they are all USB 3.

My guess is that its my Samsung 980 Pro M.2 NVMe drivers which its looking for but the ASUS X670E-E downloads do not have any specific drivers for M.2 NVMe. IMG_4559.jpeg

Any ideas?


Level 14

First, update your BIOS.  Your board may need a newer BIOS to properly support 7000X3D CPUs.

Second, make sure you are using a 22H2 installer.  If you downloaded the installation media this year, it should be 22H2.  Did you create your USB installer with the official Microsoft installation media creation tool?  Some third party tools for creating the installer can be problematic.

Third, reset your BIOS config to "load optimised defaults", in case there's something lurking in the config.

Last, the Samsung NVMe drivers come from Samsung.  ASUS don't provide NVMe drivers as the generic Microsoft NVMe drivers work for most drives.  I thought the Samsung drivers were just for performance, i.e. it should still install using the generic MS driver, but not certain.

Thanks for your response.

  • Updated BIOS to latest from the motherboard support page
  • Reset BIOS to Defaults
  • Downloaded the official "Media Creation Tool" from Microsoft to create the bootable USB (It should be the latest 22H2 as I just did this yesterday)
  • I'll try and look for the Samsung drivers on their website, but I agree, I was under the impression that generic MS drivers would handle this case

Still getting the same error.

Level 8

Just wanted to update that it finally worked - all on its own. I didn't do anything different. Bizarre.