cancel
Showing results for 
Search instead for 
Did you mean: 

Bluetooth became unbearable

romax
Level 8

I have a older RAMPAGE V EXTREME/U3.1 X99 (DDR4) (LGA 2011-v3) on windows 10.

Never had any issues but now the Bluetooth mouse is becoming super laggy although its only 1 meter away from my antenna, which functions as a wifi adapter as well i believe.

 

Is my Bluetooth out of date? i have Bluetooth 4.0/4.2

I tried a Bluetooth 5.0 dongle but that was interfering with my wif internet so i gave up on that.

Any tips are really appreciated! 

277 Views
10 REPLIES 10

Nate152
Moderator

Hello romax

There is a Bluetooth driver update you can try, click the link and scroll to Bluetooth.

RAMPAGE V EXTREME - Support (asus.com)

If updating the Bluetooth driver doesn't help, you can also try updating the Chipset driver, the Wireless driver and Asmedia driver.

R5E Bluetooth driver.png

 

 

 

Hey Nate thanks a lot for the reply and the link.

 

I updated it and some others to be sure but still facing the same issues.

If i run the Bluetooth troubleshooter it works super smooth for a while but the lagging returns within one minute/45 min, really random and obviously annoying.

I work with a brand new mouse from Logitech MX Anywhere 3s, distance to motherboard antenna is 1 meter so that shouldn't be the issue.

I have no idea what can cause this, is my motherboard too old?

 

Realtek bluetooth adapter 4.2 (in use)

Bluetooth usb module 4.0 (not in use) 

Capture.PNG

Not sure if this helps 

Thanks again!

Capture 1.PNG

Capture.PNG

Nate152
Moderator

Sorry to hear that didn't help.

Are you on the latest motherboard bios? I see in the bios versions, bios 3801 shows "Fix Logitech devices issue".

You could try 3801, 3902 or the beta bios 4101.

RAMPAGE V EXTREME - Support (asus.com)

If that doesn't help, here are some things that might help.

realtek bluetooth adapter.png

10) Update the Bluetooth driver (which you already did).

 

 

 

Hi again Nate

 

First of all i really appreciate the help and tips you give, bless you.

 

I'm def not on the latest bios, although I've tried to update it without succeeding a few times in the past.

I tried again after your response and got caught in that scary blue screen at start up issue, which thankfully through holding the shift button at startup, and performing the trouble or error fixing option got resolved again.

I honestly find it scary haha

I will make time for it and properly investigate how it should be done, as the AI Suite 3 option didn't work for me.

In the menu on the left there should be EZ Update or such, i don't have that option for some reason.

I did download the bios version:

RAMPAGE V EXTREME BIOS 3801
Version 3801
8.31 MB
2017/12/01
 
but didn't know how to use this further, its a CAP file that i couldn't seem to open or select/load within any software or on its own on my Windows 10 64b.
 
Thanks for the screenshot as well, i already had all these steps taken from googling/youtubing.
 
 
Ill try a step for step how to update bios with a usb, maybe thats the best way for me.
 
Cheers!

Nate152
Moderator

All right,

Follow this video to rename the bios file and put it on your usb flash drive.

 

1) Once you have the bios file on your usb flash drive, shut down your pc and let the psu switch on.

2) Insert your usb flash drive into the bios flashback port.

3) Press and hold the bios flashback button until your usb flash drive starts blinking, then release.

4) When the blinking stops, the update has completed. Start your pc.

rampage v extreme  bios flashback.png

 

 

 

 

Thanks a lot Nate, sorry i was out of the country to follow up,

Will try this this week.

Hi Nate

 

The bios flashback button does not seem to work, i see no movement or noises, the usb also doesn't blink after i followed all your steps securely.

While checking this issue on the forum, another forum post stated:

 

I have Maximus VIII Extreme/Assembly mainboard and to perform USB BIOS Flashback, I had to unplug al...
 
You think i should try that? remove all usb's and have the pc 'bare' so to speak?
 
Ps: brand new usb fat32 formatted, usb socket is working in general.
Romax

Nate152
Moderator

That shouldn't be necessary.

Try pressing and holding the bios flashback button until it starts to flash. If it's not working, try using EZ-Flash in the bios. You can let your usb flash drive connected to the bios flashback port.

Enter the bios and go to the Tool tab, click EZ Flash, find your usb flash drive with the bios file on it. You can tell which one it is by the size of your usb flash drive.

Click on it and it should ask you if you want to update.