cancel
Showing results for 
Search instead for 
Did you mean: 

BIOS Update. Boot linux error

Odin_NAI
Level 7

Hello, I have the following setup: Asus Z790 Hero i9 13900k dual GPU RTX 4090 4 Kingston DDR5 memory sticks kf560c32-32

After installing 4 memory sticks with an XMP profile, I started experiencing errors. Checking the BIOS updates, I noticed that the latest BIOS version 2102 improves DDR5 memory compatibility (currently running version 1303).

After updating the firmware, my Windows and GRUB Linux bootloaders broke. I managed to fix Windows, but couldn't repair Ubuntu. I attempted to create a bootable disk with different Linux systems, but none of them would boot, with the standard error message being "can't allocate kernel ...". Ultimately, after trying different firmware versions, I found that everything worked again on version 1303, but I can't use the XMP profile.

Does anyone know what might be wrong with the new firmware updates for the motherboard?

202 Views
4 REPLIES 4

Jiaszzz_ROG
Customer Service Agent

Hello, @Odin_NAI 

May I inquire if you are currently using the ROG MAXIMUS Z790 HERO or the ROG MAXIMUS Z790 DARK HERO?
What are the part numbers of the four installed memory modules, and are they listed in the motherboard's memory QVL?
We suggest installing a single RAM module in the recommended slot according to the user manual, then attempting memory overclocking settings and booting, and once the system stabilizes, gradually adding more memory.


Additionally, please pay attention to the "purchasing and installation guide" on the Memory QVL page:

Ensure that all memory modules are from the same validated memory kit. Do not mix DIMMs from different memory kits—even if they are the same brand and model (e.g., two DIMMs each from two different memory kits). Mixing and matching DIMMs can result in a failure to boot and compatibility issues. In particular, the stability of a system with mixed DIMMs cannot be guaranteed when XMP (Intel)/D.O.C.P (AMD)/EXPO (AMD)/AEMP/AEMPII is enabled. For example, enabling XMP (Intel)/D.O.C.P (AMD)/EXPO (AMD)/AEMP/AEMPII to speeds above DDR5 4800MHz or above DDR4 3200MHz could result in an unstable system.

Regarding the operating system, please note that the mentioned motherboards only support Windows OS, kindly cross-test with Windows OS if needed.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

dennys2009
Level 9

Hi!
You have a problem with TPM and keys. Before updating the bios, the keys must be exported, and after updating the bios, imported back.
Maybe this will help you:  https://www.thewindowsclub.com/the-tpm-could-not-be-initialized-after-bios-update

Odin_NAI
Level 7

I solved problems with operating systems.
However, the XMP profile does not work with 4 ddr5 sticks.

Hi!
Try installing only two memory modules in slots 2 and 4 from the processor.