cancel
Showing results for 
Search instead for 
Did you mean: 

B650E-E - Some rear I/O USB ports non-functional

Saturnine
Level 9
I recently got a b650e-e system set up, and noticed that some of my USB devices weren't working. Normal troubleshooting, I just unplug and replug somewhere else - worked - good to go, moving on.

But lately, as I've added more devices occasionally or moved things around, that certain USB ports just will not work regardless of the device I plug in. I'm on the latest chipset drivers, BIOS is on the 11/18 release, but the USB 3.2 Gen 2 Type-A ports labelled E1, E2, and 3 (Also, why this naming pattern?!?) all do not work. Haven't had the chance to confirm if the USB-C in the same column has the same issue. (If you're looking at the B650e-e's manual - this is page 2-22, and is the first column of USB ports after the HDMI and DP ports)

What's the deal here? The USB controller for these ports is installed and not reporting issues, and all USB ports with these labels are listed and marked active in the BIOS. Anyone else on this motherboard with this issue?
9,978 Views
57 REPLIES 57

Nytem
Level 7

@Saturnine @nllelobr @LEK 

Hello! I'm very late to the party here haha, I recently purchased a Strix B650E-E and after installing an NZXT Internal Hub I quickly found myself to this thread here. I encountered the very same issue and had the very same fix of just taking out the hub, however, that wouldn't do for me as I have a fair amount of headers and zero willpower to return my hub and buy splitters (which maybe could've resulted in the same issue).

I'm replying with a possible fix as I have gotten all ports active while still using the hub! And @Saturnine I saw your message that says you don't have a hub causing the issue but this may fix yours too I hope.

On windows 11 here, basically what I did was I went to Control Panel > Hardware and Sound > Power Options, Then on your power plan options (balanced or power saver, whichever you use), click on Edit Plan Settings. After that, I clicked Change advanced power settings. Once in the advanced settings, go to USB settings > USB selective suspend setting, and change the setting to Disabled. Image here: https://imgur.com/JvTf8T8 

While it does make it so that the USB ports can't be suspended if not in use, it did seem to reactivate the data lines on the ports when I plug devices into them, I had the same problem where power was coming through, just no data.

Overall a really weird issue but I hope this helps you guys and anyone else who stumbles into this thread in the future!

Snowberry
Level 7

I changed the setting according to you but it still didn't work. However, I found this by accident that could be the reason. I have a 4 port usb 3.0 hub that's a type c. If I connect the hub using the USB 3.2 Gen2 type C port C2, that's when forementioned E1, E2 and 3 fails to recognize a device. I currently have the hub connected to the USB 3.2 Gen 2x2 type C port C6 and all is well after numerous soft restart and hard shut down (unplug power after shutting down). I suspect there are some hardware issue or software issue that is causing this but I am not sure. I am using bios 1636 instead of the new 1654.

Only other thing I did that may also help is I went to Device Manager > Universal Serial Bus controllers, then on everything I could in there I clicked on their Properties > Power Management, and then disabled "Allow the computer to turn off this device to save power".

I did that before doing what I did in the power management settings in my previous message, but that didn't work at first. Perhaps both together fixed it, or maybe cause I never restarted my PC after disabling that option on all the controllers. This is way too weird of an issue lol.

Edit: Forgot to mention before I myself am using BIOS version 1654 (latest as of me typing this message) and the only change I really made to it was turning on EXPO.

This is indeed too weird of an issue, that's why I thought it might be some software issue. I mean...those ports still has power even when they are not working. I wonder if it is ever going to get fixed. Good thing I don't use any external storage that uses usb gen 3.2 2x2 so I just plug my usb hub going there instead. 

Mainblack
Level 7

※ I'm using GPT Chat translation, sentences may sound awkward

Hello,
I am using a B650E-E motherboard with an NZXT 360 cooler, an H9 Elite case, and an NZXT hub. When I connect the NZXT hub or the Y-splitter jack, the rear USB 3.x port does not work. now I am using bios 1636

When I used the BravoTech 3100mv2 case and only connected the NZXT cooler and pump to the header, there were no issues. However, the problem arose after switching to the NZXT case. Since I needed more headers due to the system cooler, I purchased the NZXT hub, but the issue occurs when I plug it in. Interestingly, if I boot the computer with nothing plugged into the internal headers first and then plug in the NZXT hub header afterward, there are no issues. I can use it well even after rebooting. However, if I power supply down and then restart, the problem reoccurs.

Anyway, since purchasing the B650E-E motherboard, there have been cases where USB does not work properly (such as Logitech wireless mouse not working properly or USB connected to HTC VIVE PRO2 not working properly when left idle for a certain period of time)

Can you set USB power delivery in Soft Off State (S5) to enabled? Use the search function if unable to locate it. Report back if this resolves.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Yes, that setting is already activated.

Yup, I just had a power outage and the issue occurred again, making my USB ports not work.

I booted up the PC with the NZXT hub unplugged, turned it off, plugged the NZXT hub in, powered the PC back on, and it works fine again.

So it seems the second the power supply gets fully powered down (from the switch on the back or a power outage), The issue starts again until you do the whole restart and plugging process. Guess the best way to protect it from reoccurring would be to put your PC on a battery backup, and pray it isn't a long outage and just a flash lol.

This is a really strange issue, and it's weird that needing to boot without it first and add it after is a fix...