Showing results for 
Search instead for 
Did you mean: 

B650E-E - Some rear I/O USB ports non-functional

Level 9
I recently got a b650e-e system set up, and noticed that some of my USB devices weren't working. Normal troubleshooting, I just unplug and replug somewhere else - worked - good to go, moving on.

But lately, as I've added more devices occasionally or moved things around, that certain USB ports just will not work regardless of the device I plug in. I'm on the latest chipset drivers, BIOS is on the 11/18 release, but the USB 3.2 Gen 2 Type-A ports labelled E1, E2, and 3 (Also, why this naming pattern?!?) all do not work. Haven't had the chance to confirm if the USB-C in the same column has the same issue. (If you're looking at the B650e-e's manual - this is page 2-22, and is the first column of USB ports after the HDMI and DP ports)

What's the deal here? The USB controller for these ports is installed and not reporting issues, and all USB ports with these labels are listed and marked active in the BIOS. Anyone else on this motherboard with this issue?

Level 7

I requested help and ASUS does not really seem to care, which pretty much sums up my experience.

Has anyone of you returned the board? Any suggestions for a replacement with SPDIF support?

Don't want to have a broken board for the next years.

In the beginning of my issue, I was exchanging emails with Asus support, they gave me some standard things to do, and other procedures I had already done before. And they even waited for my results, in the same email they say:

If nothing works, we recommend to start a RMA process.

Level 11

Just wanted to revive this topic as I am planning to buy the same motherboard (B650E-E) and have seen that many people complain about non-working top three USB ports on the back panel. I even watched a video in  YT where some guy had the same issue, had replaced the motherboard with another B650E-E and had exactly the same problem with the second motherboard again (so he RMAed and replaced it with a mobo from another manufacturer)!

Does this problem still exist for most of you? Did the new BIOS versions manage to fix this issue? Thanks!

Level 10

I got lucky, that my issue was related to an internal NZXT hub plugged in the Mobo internal USB 2.0


After removing it, the issue was gone, and never came back, even with different BIOS.

You mean that using internal USB 2.0 connector deactivates part of the USB3 ports on the back panel? Sounds quite weird, like the mobo doesn't have enough lanes (or whatever they are called) to support all of the USB ports. But if so, Asus should not have installed so many ports, in the first place.

Yeah, that was my solution. Once was fixed, I didn't continue to try other options hahahaah or checked if new firmwares fixed.

Level 7

I am having the same problem the only USB ports that work for me is the ones on my case and the USB 2.0 ports on my Motherboard (Asus B650E E). Have you fixed it yet? I have been trying everything and When I first got my motherboard not all of the ports worked either so it must be a defect or something maybe?

You mean that none of the USB 3.x ports on the rear backplate is working? 😲 It sounds very discouraging for this motherboard because I have heard complaints about the USB ports mainly for this board.

"When I first got my motherboard not all of the ports worked either" - You mean that those ports are not working since the very beginning or that some of them stopped working after time? Have you tried installing the latest drivers and so on?

Level 9

I just registered here after becoming crazy and suddenly randomly finding this and another thread with the same issue.


B650E-E, same 4 USB back ports not working at all, 2 bios tried, every config, no usb connected on the mobo, 4080 and 7800x3d with 32gb of corsair memory

I've tried absolutely everything, and no, this is not a driver problem as the usb doesn't even work on the BIOS, it's probably a faulty design by asus on this motherboard, ask for a replacement or buy another model

Level 9

I've got today a second board, and this also have the very same problem.


Went today to the shop to get another to try luck, and this board also have the very exact same problem. As I said, I think it's time to ditch this mobos for am5.