Showing results for 
Search instead for 
Did you mean: 

Asus ROG Z790 Maximus Apex big problems BSODs

Level 7


So I bought this expensive but nice MB. I'm quite dissapointed with it. I'm keeping getting BSODs like if somebody was firing from machine gun. I did frensh install of WIndows 10, everything seemd alright. Windows nad Armory crate were downloading drivers etc., but after on average 5 - 15 min usage my PC crash and give BSOD, then BSOD continue to be one after another to the point, where even in login screen into Windows I'm getting it. Unfortunately BSOD screen is so fast that I can't read error message there. Only once I managed to saw error and it was WHEA_Uncorrectable_Error

I also observed that sometimes in BIOS in Boot section my SSD is not visible, then after another restart it is again, but still getting BSODs

I did a lot of reinstalls of windows in hope that it will get somehow resolved, but it didn't. But after last reinstall I encountered one problem more and it's that my internet connection just isn't working. My Ethernet controller is visible in Windows, but disabled. If I enable it, the window says it was enabled, but status is still disabled. Sometimes it completely dissapears from Network Settings. But I'm not sure if this particular issue is related to BSODs etc. It might be corrupt Windows install, I don't know

My PC specs:

CPU: Intel i7 12700k
MB: Asus ROG Z790 Maximus Apex
RAM: G.Skill Trident Z5 RGB - DDR5 - Kit - 64 GB: 2 x 32 GB - DIMM 288-PIN - 6400 MHz / PC5-51200
SSD: Samsung 970 Pro 512 GB
GPU: Asus ROG Strix 4070 Ti
AIO: Galahad 360 V2
PSU: Asus ROG Loki 1000W Platinum
Case: Lianli O11 Dynamic Evo combined with NZXT and Lian li fans

I have also at home Asus ROG Strix Z690 Gaming Wifi D4 with T-Force Xtreem 64GB RAM, which I planned to sell eventualy, but I did try to switch them for Apex + G.Skill and I runned it for like 2 hours and didn't have single one BSOD, even internet connection problem somehow was solved. Don't ask me how, connection just started working after few minutes in system

So based on this, my thoughts are that I got a bad MB. Becauase I did also run memtest86 via BIOS on Apex MB and G.Skill RAM and it passed with 0 errors. But I have not idea if this 100% means that RAM is ok and problem si definetly in MB

So are there some steps what I should try to do or stuff like that, that could solve my problem before I proceed to send motherboard for warranty claim?

Thank you


Level 12

update bios. 

For that board windows 11 

bios 0904 and  ME firwmware

you can use Mr Mokichu drivers (give thanks on forums)

Chipset: 10.1.19444.8378  Mei 2251.4.2.0 and IO 30.100.2237.26

Is soldid no issues. the apex is solid the new bios for z790 will be also. if i can do it anyone can do it

you can find the repository (that is also updated here) [INDEX] All My Firmware/Drivers/Software Threads - Republic of Gamers Forum - 827232 (

Now the new bios also make some tweaks on the ram. For me, is as solid as a race car. I use 6000 and i did a light basic oc and solid. 




Learn, Play Enjoy!

Thank you for your advice. I updated BIOS for latest version from official site and it didn't solved my issue at all!

About drivers. Why would I exactly download and install drivers from guy who I don't know who he is instead of official drivers from board manufacturer and official website?

I feel like none of this will solve my issue

Also I don't understand what windows version has to do with my issue. I already tried Windows 11 and again not solved my issue

I'm just getting constantly BSOD WHEA_Uncorrectable_Error and my ethernet controller for some reason is randomly stoping working. I'm just tired of this. Spend so many hours trying to solve this. Like sometimes I get 10 BSODs right after earch other and sometimes I can be at my system for 1 - 2 hours wihout BSOD, but then it will start again. Like updating things or collecting dump files take me a hours, because constant BSODs and restart, so I can't even normally collect these things from my system

It looks like problem is in MB. I might be wrong offcourse, but I don't know, I'm very disappointed with such a expensive board

Customer Service Agent

Hello, @Enochian7 .

For the BSOD problem:
Please refer to [Motherboard] Troubleshooting - No Power/No Boot/No Display and test with minimal components to isolate the possible cause.
If possible, please cross-test with another SSD.

For the Ethernet problem:
Could you please help check if the following setting may have solved the problem?
Go to Intel(R) Ethernet Controller Properties> Advanced >select the Property "Energy Efficient Ethernet"、select Value to "OFF".

Please share the BIOS version, the content of the setting in BIOS (or whether it is the default), and the current version of the Intel I225 / I226 LAN Driver for us to better understand the scenario.

Thank you.


After days of trying different combinations I might finally found cause. It's not 100%, it needs to be tested more hours I think, but if I populate only 1st RAM slot with RAM stick, then I don't have BSODs yet and I tried both my RAM sticks in that slot. So maybe there is faulty 2nd slot for RAM on that motherboard 

Ethernet problem might be solved that I reinstalled windows. But if this appears again I will do what you are suggesting

For BIOS and Drivers I downloaded latest versions from here

So 0904 BIOS and LAN is Intel I225 / I226 LAN Driver V1.1.4.38 For Windows 10 64-bit.
Intel I225 / I226 LAN Driver V2.1.3.3 For Windows 11 64-bit.
NDIS Driver V1.1.3.34

Thank you

Memtest86 is glacially slow when testing large densities, and not nearly stringent enough to fully test OS stability. I tend to use it quickly for a baseline, or for faulty memory modules. Most frequencies above stock speeds are going to be tough with this much memory, so don't feel too defeated if you come unstuck. Report back if you need any help.

Here are a couple of alternatives whilst you evaulate stability:

Karhu Ramtest
Get it from here, 9.99 euros / lifetime license:

Configure the settings to your preference in the graphical user interface and
click the start button to begin testing. To stop testing, just click the same
button again.

It is recommended to run the test for at least 10 minutes before drawing any
conclusions about the stability of your system memory.

To detect intermittent memory errors you should let the test run for at least one hour.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090


First of all. I'm not trying overlocking anything on that PC and didn't overlocked anything

I did buy that software what you suggested. I did run it for like hour and no errors happened

I noticed quite few strange behaviour of my PC. I don't have BSODs anymore yet, after I updated BIOS and did also clear CMOS, but PC i still hardly usable in normal way

If I populate 2 RAM sticks, my CPU frequency is constantly hitting 4,5 Ghz, when I'm ONLY on desktop
If I populate 1 RAM sticks, my CPU frequency is less often hitting 4,5 Ghz, but still way more often that it should be normal I guess, when only on desktop
If I don't touch my PC for while and it's trying to go to the sleep mode, if froze and every fan starts running on max speeds until I perform hard reset with button on my PC case
If PC is only in state, where monitor will go to the idle mode, it still froze, but without running all the fans on max. Only solution is again hard reset, because it doesn't react for clicking with mouse or keyboard

I will attach screenshots from hw Asus Armory crate and other hw monitoring software

ethernet.JPGhw info.JPGcpu.JPGram test.JPG

So I'm basically stil confused what can be causing this. CPU, RAM, MB or something else?

Any more ideas?

Thank you

So Ethernet problem happened again
I did go to the Ethernet properties > configure > power management > unchecked allow computer to turn of this device to save power

Is that what you wanted me to do?

Customer Service Agent

Hello, @Enochian7 .

No, kindly refer to the images below:


Go to Intel(R) Ethernet Controller Properties> Advanced >select the property "Energy Efficient Ethernet" and set the value to OFF.

Please refer to [Motherboard] How to fix the cable network problems of Motherboard – Troubleshooting if needed.
If the problem persists after completing the setup, please provide a screenshot of Intel(R) Ethernet Controller Properties> Advanced > "Energy Efficient Ethernet".

Thank you.