Showing results for 
Search instead for 
Did you mean: 

ASUS ROG STRIX Z790-e Universal serial BUS controller issues ( mouth and Keyboard) Device manager

Level 7

Today my pc decided to give issues with my usb devices, the mouse and keyboard. both devices shows error 

''Windows has stopped this device because it has reported problems. (Code 43) A request for the USB device descriptor failed.'' and the other usb says ''Windows has stopped this device because it has reported problems. (Code 43) The USB set address request failed.''

My mouse and keyboard are working fine as I'm typing this but the issue is after i restart or turn on the pc, the mouse and keyboard wont respond for a good minute waiting on the windows login screen which never happened before. then on device manager it shows the yellow sign with the above messages. I tried disable them then enable on there, tried driver update, tried recover windows back 3 days, tried uninstall the usb device drivers and now i updated the bios to 1202 ( latest) and still the same. Another weird thing is the front usbs on the case do not work anymore, only the usb c. ( maybe it is a connection issue and need to check first on that first after writing this).

All drivers up to date. Not sure what else I'm supposed to do. Any help appreciated...


Customer Service Agent

Hello, @Marcus31 

We would recommend clearing the CMOS and then restarting the system.
Additionally, please cross-test with different USB ports, both on the front and rear panels, and verify if there are any yellow exclamation marks in the Device Manager.
Please refer to Troubleshooting - How to fix yellow exclamation mark in Device Manager in the "uninstall the device driver" section and reinstall the driver if needed.
If the issue persists, kindly provide screenshots of the error messages and the USB ports to which the malfunctioning devices are connected.

Thank you.

Thanks sorry for long reply I fixed the issue, so the problem was connected to the power supply. I turned it off on the back after shutting down the pc and turned it back on after a few minutes and it solved the problem.

however the usbs on the front of the case half of them work now but not the other half and i noticed it was to do with the usb connection. if I move the cables sometimes they work so I think the issue is with the  desktop case not the mobo. However since I would have to unscrew the case just to get to the usb cables, I decided not to bother since it is a bit of a job and would have to disconnect most of my mobo components and other nuinsance cables. So I left it like that which is fine until i buy another case.