cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Rog Strix X-470F Gaming ftpm stays Disabled

D4rk_W0lf
Level 7
Greetings.

I'm getting a little crazy over it because i can't update/reinstall Win11 because of one simple bug that i can't fix. Somewhere between the last stable bios and the ones before the TPM simply dissapeared. I don't know when but i'm sure that worked fine before, but right now, even with the new Beta bios the ftpm just don't get recognized, i have selected hardware tpm and enabled trusted computing but i'm still with the ftpm disabled.. any ideas?
882 Views
5 REPLIES 5

Alvez_ROG
Customer Service Agent
Hello
What is your current BIOS version?
Will returning to the previous version solve the problem?
Still can't install in Advanced\Trusted computing\Security device support [Enable]?

My actual Bios is v6061 (Beta). The lastest one, i tried to upgrade to that version because the 6042 was the first i noticed that i don't have tpm, but i didn't know that in this mobo we can roll back to an older version, i need to do something specific or it's just installing the bios like an upgrade?.

And for the 3rd question.. no, right now i had it enabled but show "No device found"

Alvez_ROG
Customer Service Agent
Yes, the way to downgrade the bios is the same as the way to upgrade the version. Because you are currently using the Beta version, please help to go back to the previous official version for testing, thank you.

Sorry for my late response but i couldn't do it before.. Just gone back from Beta to the last stable (6042), like i was before when i had that version.. ftpm still not working..

Edit 1: Tried downgrading to the Bios prior (6024), the one without the ftpm stutter fix to check if that's the problem but no.. still no ftpm

Alvez_ROG
Customer Service Agent
Hi
I have a private message asking for the serial number , thanks.