cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ROG STRIX B650E-F USB Ports Randomly Disconnect

Aazure
Level 7

I started having this issue recently where the USB ports on the back of my motherboard will randomly stop working, and will not start working until I reset the CMOS (turn off PSU after shutdown). There's no specific event that causes the USB ports to stop working, at first I thought it was due to a power overdraw, but then I put my PC to sleep while I went to work and they stopped working while it was asleep so that ruled out that. 

This has been happening only with my mouse and keyboard, which were both plugged into the USB 2.0 ports (I've since moved them to the 3.2 ports to see if that fixes it). The USB 3.2 port that my headset has been plugged into seems to be working throughout these incidents, since my friends in Discord were still able to hear me. Before I moved my mouse and keyboard to the other USB ports, I was able to test and see that if I just restarted my PC without resetting CMOS, the 2.0 ports worked when I was in BIOS, but NOT when I booted back into Windows.

I've been checking Windows Event Viewer after every time the ports stop working, and there haven't been any error messages. I've also made sure that all my device drivers are up-to-date. Not sure what to do at this point, any help would be appreciated.

714 Views
6 REPLIES 6

Silent_Scone
Super Moderator

Hi,
Make sure to check with EXPO/XMP disabled to rule out overclocking instability.

This may or may not be relevant to your issue - but check USB power delivery in Soft Off state (S5) is enabled in the UEFI. This issue has since been fixed in AGESA 1100, but official updates are yet to role out.
https://rog-forum.asus.com/t5/amd-600-series/usb-issues-on-x670e-bios/m-p/951794/thread-id/4266

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

I'll keep going with my devices plugged into the 3.2 ports to see if that keeps them stable, if it doesn't, I'll disable EXPO to see if that fixes anything. It's just weird since I've had EXPO enabled this whole time with no issues. 

I checked out that thread you linked and it seems to be a different issue that they're having since I've always had that setting enabled. I also am unable to recreate the issue I have, nor does it cause any errors in device manager or event viewer.

No worries. Report back what you find. Hopefully AGESA patch 1100 will help. If not, will have to look deeper.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Moving my main input devices to the 3.2 ports has seemed to bandage the bulk of the problems, but unfortunately, the issue is still happening.

I confirmed that it's still occurring via my webcam, which uses the USB-C port on the rear IO. I've let it happen without changing settings over past few days, but can definitely confirm that the USB-C port definitely turns off along with all of the USB 2.0 ports whenever this occurs. I'll try disabling EXPO and running RAM at base frequencies and see if that prevents anymore disconnections.

MoKiChU
Level 40

Hi,

As @Silent_Scone told you, to fix your issue flash the latest BIOS 2001 (containing AGESA v1.1.0.0) for your ASUS ROG Strix B650E-F Gaming WiFi motherboard from this post from @SAFEDISK (ASUS staff) : https://rog-forum.asus.com/t5/amd-600-series/x670-resource/m-p/970418/highlight/true#M5062


@SAFEDISK wrote:

ASUS B650 Series NEW Beta BIOS 2001

1) Update AGESA to AMI ComboAM5 1100

If the BIOS version is different, the .cmo file of the previous BIOS cannot be used (bsod problem)
so need new setting

ROG STRIX B650E-F GAMING WIFI Beta Bios 2001
https://drive.google.com/file/d/1O53gu5zn1ZBO1D-oZswq1Rm7aip7qF4V/view?usp=sharing


I have/use myself an ASUS ROG Strix B650E-F Gaming WiFi motherboard with this latest BIOS 2001, no issue to report.

It hasn't solved the issue. It may have actually made it worse, I now boot up with the issue occurring rather than it happening in the middle of my usage. It affects all USB 2.0 ports on both on my motherboard and the rear IO. I will try disabling EXPO to see if that resolves it.