Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Maximus Z790 Hero with 128GB DDR5 RAM

Level 8


I have a brand new machine with the following components:
- CPU: Intel Core i9-13900KS
- Motherboard: ASUS ROG Maximus Z790 Hero (BIOS Version: 0703)
- RAM: 4 x 32GB G.Skill Ripjaws S5 DDR5-6400 CL32-39-39-102 (F5-6400J3239G32GX2-RS5K)
- SSD: 4TB M.2 NVMe Kingston KC3000 PCIe 4.0
- GPU: PNY GeForce RTX 4090 Verto Triple Fan 24GB
- Fan: Noctua NH-D15
- Case: be quiet! Silent Base 802
- PSU: be quiet! Straight Power 11 Platinum 1200W
- OS: Microsoft Windows 11 Pro 64Bit

NOTE: Since there were (almost) no available Quad 32GB DDR5 kits in Europe a few weeks back I bought two separate kits, each with 2 x 32GB DIMMs, with exactly the same properties/parameters, only the Manufacture Date is different (one pair is "Week 11/2023", another pair is "Week 14/2023").

I have a big problem: 128GB DDR5 RAM on this machine is not stable with default BIOS settings ("load optimized defaults", everything on auto, no XMP)! I see this in Prime95 Torture Test within few minutes as well as Windows and apps crashing and BSODs.

If I use just one pair of RAM (2 x 32 GB) in slots 2 and 4, and leave slots 1 and 3 empty, everything works stable even with XMP with 6400 MT/s! Also with another pair of RAM (2 x 32 GB) everything works stable! So both pairs of RAM are working correctly! But if I put both pairs of RAM (4 x 32 GB) in slots 1, 2, 3 and 4 the computer is unstable even with default frequencies! Note that this RAM defaults to 4800 MT/s in non-XMP mode and this is also the default BIOS frequency after "load optimized defaults"!

Even if I downclock the RAM to down to 3600 MT/s - which is the minimal guaranteed speed for all possible configurations:

...I get errors with Prime95 Torture Test within minutes.

Note that BIOS shows me only one XMP I profile (6400 MT/s) even though I see a long list of memory timings in AIDA64 Extreme! So I have to set the frequency 3600 MT/s manually and hope that all other parameters (CL-RCD-RP-RAS) are correctly set in this case - since I don't know them all...

My question: What should I do to get a working computer with 128GB of RAM with this motherboard with default settings?

I guess you will say: you should use paired quad DIMMs. But which one should I buy? There is no Quad RAM on this motherboard's QVL:

...and there are only two available now in Europe:

- Kingston FURY Renegade Pro RDIMM Kit 128GB, DDR5-5600, CL36-38-38, reg ECC, on-die ECC (KF556R36RBK4-128)
- Corsair Vengeance RGB black DIMM Kit 192GB, DDR5-5200, CL38-38-38-84, on-die ECC (CMH192GX5M4B5200C38)

If I buy one of these and it will not work with default settings (no XMP) - what should I do next? I guess the support here will say: it is not on the QVL list... and in this case I ask myself - why did I buy this motherboard? It is written, that it supports 128GB RAM, but there is no 128GB RAM on the QVL list...

Can anyone here tell me how to get 128GB on this mobo? I need exact DDR5 RAM model name and manufacturer...

Will upgrade to the latest version of BIOS (0904) make my system stable with the default settings (no XMP)? Will I see all available XMP profiles displayed in BIOS?

Or should I send back this mobo and RAM and buy a DDR4 motherboard where there are plenty of 128GB RAMs on QVL lists and everything costs much less and is much more stable?

This mobo wasn't cheap and 128GB DDR5 RAM wasn't cheap - so please help me resolve this issue in the best possible way...



Level 8

I returned my brand-new PC today Asus Rog Maximus Z790 Hero ATX DDR5 Motherboard, LGA1700 Intel 13th Gen, Z790 Chipset, Kingston Fury Beast RGB 64GB ( 2 x 32 ) DDR5 Desktop Memory, 5600MT/s Speed, CL40 Cas Latency, 1.25V Voltage, 288 Pin, Dual Channel Kit.

I have tried everything but still get BSOD; the best setting got me down to one error on memtest86, but it is still one too many for stability.  I am not trying to overclock or anything spectacular simply want the product / assembled PC to work without BSOD.  Is that too much to ask? I am no computer engineer, but I can help myself a bit, I simply can’t imagine how frustrated anyone is paying rather a high-end price to get something that does not work OOTB.  ASUS – this is how Intel managed to completely lose share price and equity value.  Your brand will get irreparable damage consumers are not stupid and they will hold you to fix the issues. Please do something !!!

eemmenis_za: Did you upgrade to the latest BIOS firmware? Did you clear CMOS afterwards? Did you reinstall Windows afterwards?

Yes I did, I finally had to revert to 64GB which works fine.  I will have to wait until Asus can resolve 128GB issues in a new BIOS version.  Hope they can do this - without having to jump through a million hurdles.  Disappointing