Showing results for 
Search instead for 
Did you mean: 

ASUS ROG MAXIMUS Z790 HERO - Freezing - 100% Disk Active Time - Intel ME Related?

Level 8

I've been a fan of Asus for a long time, but this problem is absolutely ridiculous. Hoping someone can point me to the right direction as I've spent no less than 30 hours on this issue and I'm at my breaking point.

System Build:
ASUS Z790 Hero
Intel i9-13900K
TG DDR5 5600 128GB Memory
4x WD Black SN850 NVMe (RAID10 - 2x ROG Riser, 1x M.2_1, 1x M2_3)
2x WD Red 500GB SATA
RTX 4070

Problem Statement:
After fresh install of Windows 11 and the system in an idle state and before any updates, watching task manager shows the disk go 100% active with 0 read / write. No processes reflect disk usage despite the 100% active state (verified through process monitor, process explorer, task manager). When disk is 100% active, no other functions work. Task manager even freezes on some occasions and doesn't update graph or stats output. This problem persists even after updating all drivers, applying all Windows 11 tweaks (disable super fetch, disable search, disable MSI on SATA/AHCI driver), installing all or some of the Intel drivers for Serial IO and VMD. Problem persists while under load or while idle. Sometimes it doesn't appear for an hour, sometimes it runs non stop for minutes on end with small breaks lasting 5-10 seconds. No way to force the freeze to occur, and appears to happen at random.

What I've tried:
Updated BIOS to 1203, then to 1303.
Updated Intel ME to 2306, then to 2316.5
Run ME FW Update Tool (tried 16.1.27 and 16.1.30)
Replaced Motherboard, Replaced all 4 NVMe drivers, Replaced all 4 DDR5 Sticks, Replaced Processor.
Removed RAID and installed Windows 11 on single NVMe on M.2_2 and one NVMe for storage on M2_3. 100% Active Time would hit one disk, then the other, but sometimes not in sequence or in direct succession. Sometimes Disk 1 would lock, unlock , then lock again. Or Disk 2 might lock followed by Disk 1. Note, none of the attached storage on the SATA controller experience these issues. Appears to be only related to NVMe slots.

I leveraged the applicable Drivers list provided by MoKiChU found at the below link:

Not sure where to go from here. Any feedback would be greatly appreciated..


Super Moderator


Can you confirm you've tried the latest validated drivers on the support site? MoKichU's drivers are unofficial so have yet to go through any internal validation at ASUS.


13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Can confirm I've tried the drivers listed on the support site or directly from Intel. That was my first place to check. Only after everything else failed did I try drivers from MoKichU's list.

Is XMP disabled? Given the components you’ve replaced it sounds like a configuration issue. Have you seen any other reports online of this behaviour? Maybe check with LatencyMon.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

XMP is presently not in use and motherboard settings are at default minus the changes referenced in the ASUS RAID guide. Though, issue still persist when XMP is enabled. Worth noting this issue seems to appear when a combination of intel drivers are installed. Installing the Intel Serial I/O driver to fix the unknown device issue related to PCI devices in device manager caused the most recent iteration of disk locks. Uninstalled the the devices and deleted the drivers and have been stable for about 6 hours. If it remains stable and functional, guess I really don't need whatever the Serial I/O driver brings me.

Fresh install of windows 11 attempt number 22 😞

System appeared to run okay for about 8 hours before the disk lock returned. Currently operating on a fresh install with ONLY the wireless driver installed. I think the best approach here is to send the motherboard back and opt for something else. 

No less than 10 minutes after my last post the lock returned. Defaulted back to yet a new install of windows 11 with no driver support, and before I could even load the wireless driver the disk locked up yet again. 

Calling it quits with this motherboard. Will find an alternative that meets my needs without the pain and suffering.

Kind regards.

Customer Service Agent

Hello, @RaptorBiscuit 

May I ask where you downloaded your Intel ME version from?
Upon confirmation, the Intel ME version corresponding to the BIOS 1303 of the ROG MAXIMUS Z790 HERO is version

Please refer to the steps outlined in the [Motherboard] Intel® Management Engine Firmware Update Instructions(ME) to ensure you have installed the correct version.

If the problem persists, to further address your problem, could you assist in confirming the following issues?
- does the situation described also occur when only installing the system drive?
- have you attempted to format all disks to ensure there are no viruses or malicious software?
- provide a complete video recording of the issue, including disk activity in the task manager after a cold boot without running any programs.

Thank you.

All initial attempts at resolving issue used Vendor provided software and drivers. These were pulled from the ASUS support site for the z790 Hero. After I had no success, I opted to try a few of the drivers from MoKiChU, but those ultimately did not help either.

To answer your questions:
 - The situation described occurs after a fresh install of the operating system. No other software installed, not even drivers outside of windows default drivers. But issue still persisted after applying ASUS drivers
- I have formatted all disk, replaced them with brand new disk, tried a single onboard NVMe, tried single Hyper M.2 card NVMe, and various other combinations of drives and RAID settings. And unless windows installs malware like rootkits with its OS that are undetectable, I did not have malware.
- I am unable to provide any video recordings as I have returned the motherboard, and opted for a different model that works without any problems. I really liked this board, and am disappointed I was never able to get it to perform without issue.

Not sure how to close this thread, but if you are able, please do so.

Kind regards,