Showing results for 
Search instead for 
Did you mean: 


Level 8

I have an ASUS ROG CROSSHAIR X670E HERO, which I do not have any issues with generally. 

When I purchased this MB, (Dec 2023) I updated the BIOS (to BIOS 1807 the most recent BIOS at the time) using the AI Suite 3, EzFlash option, which is simple to use and I have used this on all my Asus MB’s I have owned. My recent BIOS update is the BIOS Version 1904 Dated 29/1/2024, which installed without any issues in January 2024, using the AI Suite 3 BIOS update option.

I have seen that there is a new BIOS 2007, which I have attempted to update to, using the AI Suite 3, EzFlash option. When rebooting from the software, my PC, just shuts down. Normally, it would reboot and go into the BIOS and just start updating the new BIOS. I tried this a couple of times and it did the same thing every time. I updated the AI Suite 3 to the latest version, to find the BIOS update part of the software has been removed.

So I went down the road of a USB install. Formatted a 4GB drive to Fat32, put the renamed BIOS on the drive and booted into the BIOS. Went to the tools and EZFlash tool and attempted to update the BIOS.

The first message I received was the ‘Important Notice!!!’ which is normal.

‘Please backup your bitlocker recovery key and suspend Bitlocker encryption in the operating system before updating your BIOS.

To avoid unpredictable situations, please load default settings before updating the BIOS.

The system will restart before updating the BIOS.’

I continued, as I don’t use bitlocker and it’s not enabled on my drive, so I don’t have any recovery keys to backup.

Then there is a message giving me information about the new BIOS and saying ‘You will NOT be able to roll back your BIOS after updating your BIOS to this version.’

So I continue and the update process starts, with the new BIOS information at the bottom of the screen and a progress bar appears. After about 3 seconds, my PC shuts down! It doesn’t restart, it just sits there and nothing happens. When I press the power button, my PC starts as normal.

I then reset my BIOS to default settings and tried again. I get the same result, the PC shuts down!!

The only other option open to me, is to use the flash back option at the rear of the motherboard, which I am loathed to do, as updating the BIOS the normal way, should work, it has many times before??

I have never had this issue before. Has anyone got any other ideas?? Many thanks.



Customer Service Agent

Hello, @BomberH 

Could you please confirm if there have been any other issues besides the incomplete BIOS update, such as BSOD or boot failure?
ASUS offers three methods to update the motherboard BIOS: updating via the BIOS menu (EZ Flash), through the Windows system (EZ Update), or using USB BIOS FlashBack.
If necessary, we suggest considering updating the BIOS via BIOS FlashBack and clearing CMOS after updating.
Below are the relevant FAQs:
[Motherboard] How to update BIOS of the motherboard ?(Include different generation CPU)
[Motherboard] How to use USB BIOS FlashBack™?
[Motherboard/Desktop] ASUS EZ Flash 3 - Introduction
[Motherboard] EZ Update - Introduction

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂