Showing results for 
Search instead for 
Did you mean: 

Asus Motherboard Stuck on f2 or Del

Level 7

Recently, I just had a multiple blackouts due to severe weather. Now my pc won't connect to the internet. It can boot into windows just fine but no wifi So, I replugged every cables, including ethernet, usb, etc. That didn't work so I restarted my pc, checked for updates, reset my wifi. Still no luck. I'm receiving wifi through my phone and other devices but not my pc. So, I cleared cmos and now I am stuck on the bios screen press f2 or del however pressing them on my keyboard won't do anything. I tried every usb slot and no luck on my keyboard. I tried updating and reinstalling bios and still no luck. I really need help.

Asus Rog Strix X670E-E Gaming WIFi

AMD Ryzen 9 7950X3D

ASUS ROG Strix GeForce RTX 4080

Artic Liquid Freezer II 360 A-RGB AIO



DDR5 G.Skill Trident Z5 Neo RGB 2x16 6000MT/S (I have 4 of them so 64 GB of ram)

ASUS Rog Thor 1000W Platinum II


Customer Service Agent

Hello, @WolflexZ 

Due to the ongoing local holidays in our area, my response time may experience delays.
I apologize for any inconvenience the delayed replies may have caused.

Based on your description, initially, the system could enter but couldn't detect Wi-Fi.
However, after clearing CMOS, the issue shifted to being stuck on the screen prompting to press <F2> or <DEL> to enter the BIOS with no response to any input.
May I inquire if you can access the BIOS at this point and if the system boots without pressing <F2> or <DEL>? Is the current BIOS version 1904?
Have you attempted cross-testing with a different wired keyboard?
Meanwhile, we suggest you refer to [Motherboard] Troubleshooting - No Power/No Boot/No Display and test with minimal components to isolate the possible cause.

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂