Showing results for 
Search instead for 
Did you mean: 

AsIO3.sys access denied to install Ai suite 3

Level 8

Hi, I've dealing with this issue for some days, I had Ai suite working without any issues, I installed Armory Crate and used it, then uninstalled it because I only wanted it for my motherboard, since then, suite didn't want to work, I uninstalled it and tried to install it back but I'm still getting this error and tried a lot of things but nothing is working, please help. I'm trying to install it directly from the AsusSetup with the administrator option. Now I can't totally control the fans, I tried from the Bios but it's not the same. 

System: Windows 10 home // Intel i7-10700k // Rog Strix z490-G Gaming (WI-FI)








Customer Service Agent

Hello, @Castiiel .

May I confirm if you encountered the error message in the screenshot when you tried to open Ai Suite 3 after removing Armory Crate? Have you attempted to reinstall Ai Suite 3?
Could you try to reinstall Armory Crate and use the Armory Crate uninstall tool from the support page of the ROG STRIX Z490-G GAMING (WI-FI) on the website to remove it completely before verifying the problem again?

Thank you.

Hello, the error pop ups when I tried to use the Ai suite 3 installation tool, the one called AsusSetup, I re-installed Armory crate and used the Armory Crate uninstall tool from the support page of my mobo, but the error still popping up when I try to instal Ai suite again. Also, I used the Ai suite 3 uninstall tool too, I tried to open the program that give me the error, it's called atkexComSvc and it give me the same message, I attached the ss here, thanks for the reply too, sorry for any misspelling as english is not my first language. 




Customer Service Agent

Hello,  @Castiiel 

I apologize for the wait.
According to the confirmation from the relevant department, it appears that the error you encountered is due to the missing ASUS service files, most likely caused by an incorrect removal process.
We suggest trying to reset the Windows OS and then reinstalling the Ai suite 3 to see if the issue is resolved.

Thank you.

Thanks to you, no worries, I'll try that and let you know if it worked.