cancel
Showing results for 
Search instead for 
Did you mean: 

All EXPO settings dissapeared from BIOS, only AEMP option given.

techbear
Level 10

I have an ROG Crosshair X670E Extreme mother board. Looking into the BIOS there no longer seems to be any EXPO options availiable when there was previously only Auto, Manual and AEMP. The RAM is in the QVL and was using EXPO profiles the last time I had checked the settings. Is this normal behaviour?

273 Views
5 REPLIES 5

Jiaszzz_ROG
Customer Service Agent

Hello, @techbear 

May I inquire whether the situation you described occurred after any changes were made, such as updating the BIOS or installing new memory?
Is the current BIOS the latest version, 1905, released on February 7, 2024?
After clearing CMOS and rebooting, can you confirm the presence of memory overclocking-related settings?
For guidance on setting paths, please refer to [Motherboard]How to optimize the Memory performance by setting EXPO in BIOS?
If you are unable to confirm the settings, please provide images of the main page and Ai Tweaker page under BIOS, along with the following information for us to better verify your issue:
- the current BIOS version and all the images of manually adjusting items in BIOS
- the brand, model name, and part number of the DRAM currently installed
- the brand and model name of the CPU, GPU, SSD/HDD, and PSU currently installed

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

Hello @Jiaszzz_ROG I am not sure when it happened as I had left everything on Auto for a while but I am using the latest bios 1905. The RAM is Corsair Dominator CMT32GX5M2B6000Z30K 2x16Gb which supports EXPO and is in the QVL. I have tried re-seating the RAM, clearing CMOS, Using BIOS Flashback to go back to 1904 and 1807 (same result)

CPU: AMD 7950X3D
GPU is an EVGA 1080Ti SC2
SSD/HD: Samsung 980PRO 2TB/WD Black 10TB
PSU: Corsair HX1500i

Here are the screen captures of the Extreme Tweaker page, the SPD info page and the Main BIOS page. The only options are Auto, Manual and AEMP. 

240304191742.png

A2 (1).png

240307174901.png

techbear
Level 10

Hi @Jiaszzz_ROG Corsiar accepted my RMA request and I will be exchanging the RAM. Do you need any other information before I return the RAM?

Jiaszzz_ROG
Customer Service Agent

Hello, @techbear 

The configuration options for the Ai Overclock Tuner may vary based on the installed DIMM model.
May I inquire whether you have previously enabled EXPO with the same memory modules and are currently experiencing difficulties?
If so, we would recommend conducting clear CMOS and cross-testing with other memory modules or considering sending the RAM for diagnostics to identify potential underlying issues.
(Please note that the memory module with part number "CMT32GX5M2B6000Z30K" is not confirmed in the Memory QVL for the ROG CROSSHAIR X670E EXTREME.)

Thank you.

sharing complete hardware info & software config details will help us better understand the issue 🙂

@Jiaszzz_ROG I confirm that I have used EXPO successfully with these same modules for the past 9 months. Unfortunately I don't have other modules to test with or another system to try my modules with. Please also note that upon consulting with Corsair Customer Support in the past, these modules are the same as "CMT32GX5M2B6000Z30" which is in the QVL or at least that is what I was told by Corsair. I previously had a non QVL kit that was giving me issues and they replaced it for the kit I am currently using. Also the motherboard is detecting it as CMT32GX5M2B6000Z30 in the BIOS screenshot I provied previously above.

techbear_0-1709887157281.png

techbear_1-1709887626646.png