Showing results for 
Search instead for 
Did you mean: 

7590-plus wifi bios wont detect m.2 ssd

Level 7

7590-plus wifi bios ver: 1801 Intel core i9-10900k

I’ve seen other threads about this and tried researching on my own but I cant get anything to work;

Things I’ve tried: 1. Updated bios 2. Unplugged and replugged the ssd in 3. Fiddle around with bios settings. Nothing worked so I reset back to defaults exept enabled TPM device support and the re-size bar.

I’m genuinely at a loss as of what to do this being my first custom pc build and all. I’d appreciate all the help I can get reddit.


Customer Service Agent

Hello, @minibo1 

Could you please confirm if your current model is the TUF GAMING Z590-PLUS?
We recommend that you refer to [Motherboard] Troubleshooting - Cannot find the hard disk drive or SSD(M.2) after motherboard powers on first, clearing the CMOS, and enabling the [CSM] option in the BIOS.
After completing and saving the settings, please restart to see if the issue persists.
If there is an inoperable part of the process, please let me know which it is by sharing images or recording videos.

Thank you.