Showing results for 
Search instead for 
Did you mean: 

13900kf rtx 4090 strix oc pcie X8 3.0 problem asus maximus hero z790

Level 8

13900kf rtx 4090 strix oc pcie X8 3.0 problem it should work x16 4.0

before the latest bios update it was x16 3.0 but not 4.0 so i though lets update to latest 1303 bios and it made it x8 3.0 so can anyone tell me the hero z790 the problem here? i found 2-3 users with same issue and same specs.

and no i dont use ssd in any slot it doesn't matter still x8 3.0


Level 8

the card is installed in PCIe x16(G5)_1 slot. obviously. everything looks right.. i have very expensive custom water cooler build so before changing my motherboard i have to find out. anyone with similar problem? i dont want to think that maybe the gpu might be the problem

Hi, noticed you said it's a watercooling build. Are you using a riser cable? Have you tried reseating the GPU?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

only the cpu is watercooled...i haven't tried reseating the gpu tho,im thiking maybe the dirt causing it but im unsure how is that possible its not like my pc is full of dirt

Customer Service Agent

Hello, @pcgamersz 

May I inquire about which BIOS version you updated from and to which version? Did you attempt to clear the CMOS after completing the update?
Based on the situation you've described, we would recommend you swap different PCIe slots or cross-test with another GPU, and ensure that the power connectors on the GPU and the installation in the motherboard slot are correctly configured.

Thank you.

Level 10

Have you tried HWinfo64 to check the PCIe speed to show if it is Gen 3 or Gen 4?

Have you measured PCIe bandwidth throughput (as described in search for "pcie bandwidth evga forum")?