Showing results for 
Search instead for 
Did you mean: 

PG42UQ strange problems black screen/freeze screen randomly

Level 7
on firmware .31 got random black screen in the middle of game will not turn back on until i unplug power and replug. also had a random screen freeze in the middle of a game. and could not turn off or anything until i unpled. this all happen on overlock off @ 120 mhz since 138 mhz would not even wake up the screen sometimes when it goes to sleep.
also my rog logo randomly turned green looked in the manual but didnt see anything anout green logo not sure what does that mean?
hope they fix all these problem on the next firmware update or will have to return this monitor.
142 REPLIES 142

This firmware update fixes exactly your issue.

Level 8

Thanks for the response? Did you try it out of curiosity. I'm only asking because I've heard some people have tried firmware updates and had issues with their monitors after etc. I just dont want to update to the firmware then it not work or something rofl. Other than that issue the monitors seems to be working perfectly I believe.

Customer Service Agent

Hello, @Daiki 

The firmware version 028 was released on the official website just yesterday and specifically addresses the issue you described.
We recommend updating to this version and then confirming if the issue can be solved.

Thank you.

I have it 028 installed now successfully. It hasn't been long enough to know if it's fixed. But if I don't have the issue any longer I'll post here. Thanks

Level 8

Hi @Jiaszzz_ROG,


Thank you, I'll do that and update you. 

Level 8

Just an update: Been a few days. Issue hasn't occurred since the firmware update. Thanks! 

And for us with 32?

Customer Service Agent

Hello, @Cincilleo 

I apologize for the delay and misunderstanding. Could you please confirm if you are currently using the PG42UQ?
As I mentioned in my previous response to another user, we have released firmware specifically for the PG48UQ model.
Please provide the following information for us to better understand your situation:
- What are your screen settings? What is the resolution and refresh rate when the issue occurs?
Have you tried resetting the screen settings by referring to the following link?
[LCD Monitor] Troubleshooting - No display after turning monitor ON
- Are you using HDMI or DP as the screen connection? Are you using the original manufacturer's cable?
Have you tried testing with different cables or ports?
- Does the random black screen issue occur in specific situations?
For example, does it happen with a particular game or after a fixed period of time after the screen is turned on?
- What troubleshooting steps do you usually take when you encounter this issue?
Do you typically try reboot the PC or restarting monitor?
- Please share the circumstances and frequency of the problem, and contains a video that completely captures the problem's incidence and the surrounding environment.

Thank you.

Issiue is till prevalent on my pg42uq on the v.037 fw. Also blinking in hdr 10 content 

Hello all,

After the PG48UQ upgrade, I've been busy and haven't got around to ensuring 100% sure I followed the steps to try to reproduce, but I'm pretty sure the FW fixed it as it's not happened since. 

For PG42UQ users, do y'all see it at the exact same time and situation as we did? That is: monitor on, PC Off; PC on; 4 hours of use=> screen/buttons deactivated.

If yes, I think if you have a video just like I did, showing nothing going on with ur PC and the 4 hour mark comes up that shuts it off; that'll get ASUS to address it. If it's not reproducible like that, then it might be a lot more difficult to get the fix. But from what I recall reading, I thought the issue was the exact same between the models. I don't have a 42 so idk though.


Overall, I'm glad the fix is here. I'm happy with the monitor now. But it taking this long and the nightmare RMA process was not good. 

P.S. @DahakaMVl I don't overclock, but I have seen the monitor go black for a ~2 seconds before and I use HDMI. I had assumed it was something with my PC as it rarely has ever occurred, definitely less than once a day for me; and I think I've only seen it after being inactive for awhile. I thought it might have been about to go to sleep and then I brought it back up. Never during a game so far.

Maybe I'll switch back to DP with those findings, thanks. With the frequency of occurring, not worth me trying to troubleshoot with ASUS imo.