cancel
Showing results for 
Search instead for 
Did you mean: 

PG32UCDM power surge on USB port

lngrhns
Level 7

Hi,

I picked up my new PG32UCDM yesterday and installed it. It works fine overall but as soon as I plug the USB upstream ports into my PC Windows will complain that an unknown device uses too much power. The downstream USB ports consequently also don't work. Tried different USB settings on the monitor but results are always the same.

lngrhns_0-1714926387437.png

This happens on two different Windows PCs and also on a MacBook, via both the USB-B and USB-C ports. Therefore I'm sure it's not an issue on the PC or cable end. Is this a known problem? I was able to at least install FW 103 but that didn't change anything. Maybe someone else had that issue and has a hint before I have to return it (which would suck cause they are barely ever available in any shop...)

310 Views
4 REPLIES 4

Jonasen
Level 8

Bro,I have PG34WCDM,same issue,IDK what's wrong with the new gen of ROG OLED series,maybe they used the faulty

image.jpg

usb chip on the new OLED series.

Silent_Scone
Super Moderator

Hi,

I've moved this thread to ROG Care for attention of service.

@Jonasen, if using a different panel best to create your own thread 👍

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

lngrhns
Level 7

Tested this on DP, HDMI and USB-C and all exhibit the same power surge behavior. Pretty sure this is a hardware issue at this point but given this monitor is only available in stores every full moon I wasn't even able to exchange it yet. Shop told me I can send it to Asus but that would take 4-5 weeks which would be a problem without another monitor available...