cancel
Showing results for 
Search instead for 
Did you mean: 

PG32UCDM Firmware Update error

Christof1988
Level 8

Hello, I have the problem that "Asus Firmware One Key Update" cannot find my monitor. Of course, I connected the USB cable that came with it correctly. The monitor has firmware version 101 and I would like to update to 103. When I run the tool I get the error message "Get Model Name Fail". Can someone help me please?

361 Views
6 REPLIES 6

jetcat3
Level 7

I had the same issue and fixed it by unplugging and plugging back in the USB-B cable. 

Aureliannn_ROG
Customer Service Agent

Hi @Christof1988 ,

thank you for raising the issue. You can use the link provided below to update the firmware. Please confirm if the update is successful. 

https://dlcdnets.asus.com/pub/ASUS/LCD%20Monitors/PG32UCDM/ROG_Swift_OLED_PG32UCDM_FW_MCM103.zip?mod...
Additionally, you can also try the method suggested by jetcat3 to see if it resolves the problem. 
If you need further assistance or have any other questions, feel free to contact us anytime. 

Thank you.

Providing detailed device specifications (MB/CPU/GPU/PSU, etc.) and the respective driver versions, OS version, and BIOS version will help us analyze the issue more effectively.

  • Hello, thanks for the answer. But it didn't work and I still have the same error. Any other ideas? I've even tried it with another computer. But it doesn't work.

Update program not finding the monitor's model happened to me while in windows safe mode. Have you installed the drivers?

I have now bought a new monitor and the update worked instantly. It was a Monitor bug -.-

slmylmz
Level 7

Same here firmware can not finding the monitor