cancel
Showing results for 
Search instead for 
Did you mean: 

PG32UCDM Firmware One Key Update Not Starting!

cansineroz
Level 7

Hello, I downloaded the necessary file from Asus' website to upgrade the firmware of my PG32UCDM monitor, but the installation never starts. I tried many times and waited a long time, but it still didn't work.
When I start the computer in safe mode, the installation works, but this time it does not detect the monitor. Actually, I don't have much installed on my computer, it's a fresh Windows, but I haven't been able to figure out why this problem is happening yet. I tried for both 102 and 103 versions, there is no movement. It's like I never opened it...

920 Views
27 REPLIES 27

Aureliannn_ROG
Customer Service Agent

Hi @cansineroz ,

We apologize for the inconvenience you're experiencing with firmware updates. We recommend following the steps provided in the FAQ below: https://www.asus.com/support/faq/1041883

https://dlcdnets.asus.com/pub/ASUS/LCD%20Monitors/PG32UCDM/ROG_Swift_OLED_PG32UCDM_FW_MCM103.zip?mod...
Could you please specify which step you encountered difficulty with during the execution of these steps? 

If possible, please provide screenshots of the relevant steps. This will help us better understand your issue and provide a solution. 

Additionally, you can also ensure that your network connection is functioning properly or restart your computer to attempt the firmware update again. 

Thank you for your understanding and cooperation.

Hello, 

I double-click on the PG32UCDM FW update MCM103 exe file and even though I wait for a long time, nothing opens.

I tried the same thing with version 102. it doesn't open either.

I'm not a newbie, I've tried a lot of things but it doesn't give any reaction.

Any news?

Owambo
Level 8

Hi,

same here with this error:

Screenshot 2024-05-04 134316.png

- chkdsk ok
- sfc /scannow ok

what do we need to do?

Nate152
Moderator

Hello guys

To confirm, are you connecting the USB-A to USB-B cable to your monitor and a pc usb port?

You need this to do the firmware update.

 

 

 

 

 

Owambo
Level 8

Hi,

Yes. USB-B (the big one) at the Monitor and USB-A at the PC.

Nate152
Moderator

Thank you for confirming.

I have the ASUS ROG Swift PG27AQDM and was able to update the firmware without any issues with the one key method.

Something to try.

Shut down your pc and turn off the monitor with the power button. Unplug the monitor power cable and wait 30 seconds.

Reconnect the power cable, boot up and try the firmware update.

Make sure there are no other firmware update tools installed on your pc.

 

 

Owambo
Level 8

Hi Nate,

I'll tried it out and unfortunatelly its not working 😞