Showing results for 
Search instead for 
Did you mean: 

I can't get into the BIOS or Windows Advanced Options with new PG329Q monitor connected

Level 8

I've just bought an Asus PG329Q monitor, and when it's connected, I can't enter my PC's BIOS or Windows' Advanced Options screen (triggered by holding-down the Shift key while clicking Restart or Shut Down in Windows). When booting, the system completely skips over the BIOS as pressing or holding the Delete key has no effect, and boots straight into Windows. And Windows' Advanced Options screen is just a blank black screen. But when I connect my old monitor, an LG 32GK650F-B, I can both enter the BIOS and see the Advanced Options screen. It's just the Asus PG329Q that I can't enter the BIOS and enter the Advanced Options screen while using.

The system motherboard is an Asus ROG STRIX X670E-A, and I'm having this issue with both of the BIOS versions I've tried, 1415 and 1602.

It looks like lots of other people are having the same or a similar issue with entering their PC's BIOS and Advanced Options with Windows 11. And there are also a bunch of reports that sound like they could be the same issue with Windows 10.

Microsoft answers: Can't access bios or advanced startup on windows 11

But again, I can enter both the BIOS (by holding down the Delete key while booting up), and enter the Windows Advanced Options menu normally using my old monitor (and can, from there, also reboot into the BIOS), but I can't do either when using my newly-bought Asus PG329Q monitor. I've tried different keyboards, and the issue persisted with the Asus PG329Q. But my old monitor, the LG 32GK650F-B, enter the BIOS fine with the same keyboards.


My brother told me he had the same issue with his Asus mobo AM5 system, and that he fixed it by resetting the BIOS and removing the CMOS battery to clear things as best as possible, and then starting up fresh with the new monitor, and that fixed it for him. I tried that, and it still didn't work for me. Then I tried swapping the DisplayPort cables from my old and new monitors, and with the other DP cable, and then my new monitor was able to go into the BIOS and also the Windows Advanced Options menu a couple of times. But now it's gone back to doing the same thing as before.

I also tried using an HDMI cable instead of a DP one, and it again wouldn't go into the BIOS or show Windows' Advanced Options (it's just a black screen). But I've found that pressing Space while at the black screen where the Advanced Options screen should be will restart the PC, and then it seems to pretty consistently show the ROG splash screen, pre-Windows loading (which doesn't happen when I do a cold boot, or a normal reset from within Windows). So, I tried holding the Delete key after I rebooted from Advanced Options (which I did by pressing Space at the black screen where Advanced Options should be displayed), and I ended up going into the BIOS. Then, while in the BIOS, I tried switching from HDMI to DP, and I got no signal. Then I tried switching back from DP to HDMI again, and also got no signal.


Being able to access the BIOS is important for me, especially right now, while I'm trying to adjust various settings.


Level 8

I'm finding that I can consistently enter the BIOS with the new monitor if I Shift-key + Restart from the start menu, to boot into the Advanced Options screen (which doesn't display on the monitor but is just a black screen), and then, while at that black screen, press the Space key, which resets the PC again while making an Asus screen appear that says press Delete to enter the BIOS. If I'm not holding down the Delete key as the system starts booting after memory training, that screen won't display. But if I am holding the Delete key down, that screen will display and it'll go into the BIOS after that.

I'd like to note that this is a premium Asus monitor, and a premium Asus motherboard, and that both are part of Asus' latest lineup, and so they should work together without an issue like this.

I hope that a full fix is forthcoming.

Customer Service Agent

Hi @Astroplane ,

In light of the issue you've described, could you please check the BIOS settings? Specifically, is the CSM (Compatibility Support Module) option enabled or disabled? Also, could you confirm if you're connecting the monitor to the graphics card via DisplayPort? Have you ensured that your graphics driver is up to date?

Additionally, when you mentioned using DisplayPort, does it prevent you from accessing the BIOS but allows you to access the system, whereas when using HDMI, both the BIOS and system screens remain inaccessible and display a black screen?

Hi Aureliannn,

My display driver is updated as of July or August of this year.

I have the monitor connected to the graphics card via DisplayPort. As far as I'm aware the issue affects both DisplayPort and HDMI the same: With either, I could boot into Windows and see Windows fine, but I couldn't see or boot into the BIOS normally, and I couldn't see the Advanced Options screen if I Shift + reset the PC from Windows.

The CSM option in the BIOS was disabled. I've enabled it now, and that has fixed the issue. So, that's good. I still think it shouldn't need to be enabled to use a current-production premium Asus monitor with a current-production premium Asus motherboard.


I want to clarify that my system is running a fully-updated Windows 11 Enterprise install. From what I read, CSM is supposed to be required when running an older OS, and that newer OSes shouldn't need it. But with specifically my new Asus PG329Q monitor, I can't boot into the BIOS unless I enable CSM.