cancel
Showing results for 
Search instead for 
Did you mean: 

FPS counter not working properly (PG32UCDM)

Davids777
Level 9

The FPS counter sometimes shows 240 FPS when that is not the case at all.

This problem occurs with all firmware versions 

EDIT : I finally managed to identify the problem and so I made a video to show you. Sometimes when I start a game the FPS counter seems to keep showing desktop FPS so I have to click in the game window or go back to desktop before returning to the game to get the monitor to understand that it is the game window that the FPS counter should analyze. I hope this is clear enough but I am available if additional information is needed. THANKS

https://youtu.be/ZXR_pFDocKw

 

javav25sft_20240419_215841267.jpg

892 Views
1 ACCEPTED SOLUTION

Accepted Solutions

Davids777
Level 9

Thank for your responses and thanks for your tests @Aureliannn_ROG

I use HDMI because it performs better than DP.

GSYNC is enabled and I always use native resolution in Windows 11 and games. When full screen is available, this is also the option I choose but unfortunately some games no longer offer this option (MK1 among others).

The solution I found is to go back to the desktop with Windows + D and go back to the game to force focus on the game because I'm playing on the controller and it feels like as long as I don't click in the game window, monitor FPS counter focus remains on the desktop

View solution in original post

23 REPLIES 23

Swatted
Level 9

Works fine on 4 games I just tried (VRR and G-Sync ON)

Davids777
Level 9

I use it a lot and I tested 80 games (VRR, G-Sync ON, and HDR ON). It sometimes work but it stop working for no reason. I use the version with graph, maybe it's important

 

Have you noticed any pattern in how long does it take for it to stop working? When it does, is it for all games? One more question if you don't mind, even if g-sync is enabled in NVCP, can you turn the g-sync indicator on and double check it's showing up whenever the OSD counter stops updating?

Davids777
Level 9

I haven't been able to identify the cause yet but I have the impression that it happens when I change games without deactivating the counter. I need to do more testing to identify the problem but this has happened to me with several different games

I recently suffered an issue where g-sync would randomly stop working, even if nvcp stated it was eanbled, I was able to confirm this was the case by checking the G-SYNC indicator either not being present or blinking on and off alternatively in the top right corner of the screen while in game. When the indicator wasn't present, the FPS counter in the OSD stopped logging anything but 240.

Davids777
Level 9

Interesting, and did you find a solution for this ? The latest firmware is unfortunately not yet perfect. When changing HDR mode on the monitor, I sometimes have to restart Windows HDR for it to take it into account


@Davids777 wrote:

When changing HDR mode on the monitor, I sometimes have to restart Windows HDR for it to take it into account


That's a new one. Are you aware of the ⊞ + Alt + B shortcut?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Hi @Davids777 ,

 thank you for providing the information. To better understand your situation and find a solution, we need further details. 

Please answer the following questions:

  1. What type of signal cable are you currently using for connection?
  2. Have you checked the settings in the NVIDIA Control Panel and confirmed G-Sync compatibility?
  3. Does the FPS counter only display as 240?
  4. What is the actual correct FPS value?
  5. Have you ensured that the drivers for both the graphics card and the monitor are updated to the latest version?
  6. Does the issue occur in every game, or only in specific ones?
  7. Has the issue been persistent since the time of purchase?

Please provide the above information, as it will help us better understand and address the issue you're experiencing. 

Thank you for your cooperation.

Oh brother, I've tried so many things that looked promising at first only to eventually fail that I don't dare trust my current solution too much but it's true I haven't lost g-sync since applying it so...If you have the same issue where g-sync stops working even if it shows up enabled, what I did was set scaling from display to GPU in NVCP.
bUTKd3m8nU.png