Showing results for 
Search instead for 
Did you mean: 

Asus Pg27aqdm firmware update fail

Level 8

Hi all

So I cant get my pg27aqdm to do the firmware Update. I own the monitor for 4 weeks with no other problems. Got the driver of the asus page aswell. Monitor and Hub are showing in device manager and work. 

My guess is that its because i also have the pg42 (done multiple firmware updates on that) I uninstalled the old firmware updater and restarted ( as said in the read me) but the onekey tool does not seem to start properly. I shortly does something and then just says fail, task manager shows no activity. It also does not read the current firmware version

Im lost, any idea on what to do? Is there a way to put the firmware on a usb and update that way?



I've updated in the past with no problems. But now I am having the same issue, showing the same exact thing in the picture. Don't know what to do since I don't have a spare computer or laptop.


So I decided to try with my old Laptop and it worked first try with the monitor only beeing conectet via usb and while in standby mode.... 

I guess something on my main pc made the updater not work I just dont know what it is.

Customer Service Agent

Hello, @Rav3n1 

Could you help confirm if you have completed the monitor firmware update after switching to the laptop?
If you encountered difficulties during the update process on your original PC, we recommend referring to the notice and subsequent steps provided below the update SOP.

Thank you.


Yes, can confirm.

I never unpluged the usb on the monitor, just switched from the motherboard of my main pc to a usb port of the laptop.

I dont know what could cause the issue on my main pc. As I already said i did every step thats in the SOP. 




windows 10 or 11? Both my laptop and pc hjave windows 11 so im starting to think that is the issue.

True, main pc has win 11 but my laptop  win 10. Could be a win 11 issue.

Level 7

Yes, I get exactly the same as Rav3n1. Exactly. 

As you can see everything is plugged in correctly and still we get this -48 issue. What gives? 

Customer Service Agent

Hello, @RedSeptember and @Rav3n1 

Since it seems that you haven't mentioned the steps to remove the ASUS VLI FW update tool, I would appreciate your confirmation as to whether you have followed the steps in the SOP page 2 to remove the FW and restart before executing the PG27AQDM key tool to update the FW.

Thank you.

I said that I removed the update tool for the pg42 in the first Question...

But again, I followed every step in the sop,including unistalling, the ASUS VLI FW update tool, restartet pc, same result.

Anyway i will keep updating with my laptop as it works there