cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Pg27aqdm firmware update fail

Rav3n1
Level 8

Hi all

So I cant get my pg27aqdm to do the firmware Update. I own the monitor for 4 weeks with no other problems. Got the driver of the asus page aswell. Monitor and Hub are showing in device manager and work. 

My guess is that its because i also have the pg42 (done multiple firmware updates on that) I uninstalled the old firmware updater and restarted ( as said in the read me) but the onekey tool does not seem to start properly. I shortly does something and then just says fail, task manager shows no activity. It also does not read the current firmware version

Im lost, any idea on what to do? Is there a way to put the firmware on a usb and update that way?

 

2,784 Views
20 REPLIES 20

Jiaszzz_ROG
Customer Service Agent

Hello, @Rav3n1 

May I ask, when updating the ROG Swift OLED PG27AQDM, were you also simultaneously connecting the PG42UQ?
What does "uninstalled old firmware" mean? The PG27AQDM update SOP does not seem to include a step for removing the firmware. How did you uninstall it?
Also, could you further explain what "one key tool didn't start properly" means? Did you encounter an error message?
What specific situation led you to believe that the current update for the PG27AQDM has failed?
Was it a black screen issue with no display? In this state, are you able to access the OSD menu?
If possible, please provide a more detailed explanation to help us understand the current situation, or share a complete video recording of the problem.

Thank you.

Hi

No, I only have the pg27 connectet when I tried the Update (via usb and dp) 

the pdf in the pg27 updater says to unistall other firmware update tools for other rog series bevor opening the One key tool. (Not the firmware itself, just the update tool for the pg42)

The One key tool just shows as "fail". It cant read the current firmware of the monitor and the "update"button is greyed out. It shows no activity in task manager. The monitor itself never stops.

Hey there. Were you able to find a solution to this? I just recievied my monitor and I'm having the same issue trying to update the firmware. I have the USB plugged in and it still says failed and is unable to detect my current FW 

RedSeptember
Level 7

 I also want to know how to fix this! I have tried on different PC's and still get the same "windows does not recognize this USB Device"

and the update fails to detect my current FW version also. This is ridiculous Asus. Please help your customers fix this. 

Jiaszzz_ROG
Customer Service Agent

Hello, @Rav3n1 , @aPHAT and @RedSeptember .

Please make sure to follow Step 1 in the SOP, which is to connect the PG27AQDM and PC using a USB Type B cable, before proceeding with the installation update.

Jiaszzz_ROG_0-1686556227234.png

If you encounter any abnormalities, such as the executable file being grayed out and failing to update, please provide a complete video recording that includes the connection process and the issue of unsuccessful installation after clicking the.exe file.

Thank you.

We have done that. We use the USB type B cable and that is when we get the USB device not recognized by windows and the update file is greyed out and has no current version and cannot update. 

Jiaszzz_ROG
Customer Service Agent

Hello, @RedSeptember 

Could you please provide a complete video recording that includes the connection process and the issue of unsuccessful installation after clicking the.exe file?

Thank you.

https://www.youtube.com/shorts/cPDVwnFeMFE

Yes ive done that. tried every port on the motherboard. Always the same result. 

20230608_123047.jpg