Showing results for 
Search instead for 
Did you mean: 

ROG Strix Evolve multiplies mouse filters and stops responding

Level 9

I bought last year a mouse model Strix Evolve. NIce mouse, really simple layout nothing too exaggerated. One small issue, since months I started having issues, issues that I believe are caused by some sort of corrupted firmware.
Randomly when using the mouse the device stops responding, months ago it just stopped moving the cursor, which leaded me to believe the issue was an hardware one, maybe some cable issues.
Too bad that since a week ago the problem became worse, not only the cursor stops moving, but ALL the buttons stop working too during this "downtime moments" and since this is happening on a brand newly assembled PC This propped me up to do some testing and I discovered some issues.

  • First: Every time I boot up my pc with the mouse plugged in or just unplug and plug in the mouse in the hidden devices of the Device Manager a new Mouse filter pops up, almost always having 2 active at the same time and leaving behind a trail of "unconnected devices". Uninstalling all the filters minus one seems to temporarily fix the problems but it also could be Placebo; Just had an horrible game in DRG and I'm pretty sure I had one filter enabled.

Tons of filters, what are they even for?Tons of filters, what are they even for?




  • Second: I tried to reset the mouse firmware by following a thread on these forums, granted it was for a Spatha model but the key combination should be the same, unplugged the mouse, pressed right left and middle button, while pressing connected the mouse to the pc. No signs of life, LED turned off and Armourycrate prompting me to manually install the latest firmware. Problem is that with no mouse I had to replug the mouse in the pc before launching the firmware install in admin mode. That could have screwed up the firmware install.
  • Third and more importantly:The mouse was tested on my brother's laptop which has NO Armourycrate installed, no problem during the amount of time it was tested, However the problem was and is present both on my old laptop and my new pc

So i'm here asking, is there any way to completely reset a mouse to it's factory conditions and then make a clean firmware update? 




Hello Axe127,

Sorry for a late reply.

It sounds like you reset the mouse by following the spatha directions.

You could try resetting your ROG Strix Evolve again and install the firmware from the ASUS Support Center.

Maybe this will magically get it working.

ROG Strix Evolve | ROG Strix Evolve | Gaming Mice & Mouse Pads|ROG - Republic of Gamers|ROG Global (...

I've already done that. Multiple time too, but that never worked. Any other ideas before declaring it a lost cause? Where are the drivers located? I'd like to reinstall them