Showing results for 
Search instead for 
Did you mean: 

Rog Spatha Not Working, Somes Connects Sometimes Doesnt

Level 7
Hi All

I have owned my spatha a good 6 months now and it is the most annoying mouse i have ever owned.

I work in IT for a living and this mouse has been a real headache for me.

Where to start.

My mouse has been very hit and miss since i owned it, sometimes saving profiles the mouse just stops working and freezes, then i have to unplug and replugin, try different versions of the armoury and eventually it starts working.

Yesterday evening it took me 3 hours to get the mouse going, Every time i opened the rog armoury my mouse would go inverted, After hours of removing and reinstalling different versions of the armoury it started working again. I saved my buttons and used the mouse.

Come to use the mouse again today, Opened the rog armoury to make some changes and as soon as the armoury opens the mouse stops working and the cursor is frozen, So i unplug and plug back in then nothing 0 lights no power just a little white light flashes once as soon as the usb is connected then nothing.

I managed to get it working about 10 minutes ago, by removing all of the rog armoury clearing all temp files and making sure the drivers where removed.

When rebooted the mouse worked, So i reinstalled the armoury and instantly the mouse freezes and wont move.

This is a common occurrence with this mouse and to be honest im getting pretty fed up of it.

Ive used every version of the software i can find and all seem to have some issues with this mouse.

When working this mouse is great to use, hence why i have held of buying a new mouse and also the fact i stock this product in my store, and i have 2 or 3 customers who have exactly the same issue.

Ive tried doing the reset / update by unplugging the power when rog armoury is open, holding left right and mouse wheel click and plugging back in, it did try to update but no luck as the mouse seems to just loose all power.

I dont believe the mouse itself is faulty but i do believe the rog armoury is the cause of this.

Just to confirm i do not have the wireless plugged in only the USB.

Level 7
got it connected, then opened armoury and mouse froze again, now wont connect again and doesnt show any power when plugged in.

well my mouse had no power, unplugged and plugged back in and nothing.

So went to remove rog armoury, but when it was removing and it hanged on the 0 i plugged the mouse back in and low and behold it works.

So this issue is 100% software related and needs to be fixed. Does any 1 know which is the most reliable and stable software that will work?

Ive tried



Latest Version 3 from website and several other versions of 102 think and 103

I just run a test as above, run rog armoury mouse froze stopped responding unplugging and plugging back in mouse didnt respond (no lights)

remove rog armoury on 0 remove mouse and plug back in and mouse works.

ive replicated the above 3 times in a row now with the same outcome.