cancel
Showing results for 
Search instead for 
Did you mean: 

ROG SPATHA charging dock issue

ForMol69
Level 7
Hello,

I have received today my ASUS ROG SPATHA mouse. All is running fine while using the mouse. I installed armory and it directly updated firmware for both dock and mouse.


After i played with the lights for a good while, programmed my buttons and tested a few games, i placed the mouse in the dock for charging.

While positioned in the dock, the light on the mouse is continuously going flashing from green to red (color that I've set for use mode). I watched a few reviews online and noticed that in some of them the color on the mouse zones is always green while the mouse is docked.
I initially thought it is a connection issue and tried to dock the mouse as it was turned off .. every time i dock the mouse the light turns on which tells me that it is charging through the dock. In armory the battery went to 100% after a while so that also confirms that it's charging.

Does anyone else have this issue ? Is this a known issue ? Do i have a technical problem with my mouse ?

Thank you in advance for the help !
795 Views
34 REPLIES 34

I ve the same problem for months now.
But the only way to have my wireless to work again is to remove its battery and pulgging it again.
I ve bought the Spatha at US a couple months ago and to tell you the truth its annoying to buy an expensive ROG item and have this kind of ptoblem.
I ve loads of ROG products like MB ( formula vii ), mousepad ( sheath ), strix 1080 ... and thats the 1st time I m totally unhappy with a ROG product.
No direct answer from anyone ...

Asus Team, thtas not the VIP treatment you say we wold have from ROG invitations ... in fact no customer ROG or not should !

I really hope to have a better answer soon, we are working is a response that politicians tells to the mass, please be better than that!

TC

Was having similar issues too!
First of all Rog Armoury didn't "prompt" for an update to latest version (1.01.19) -check for update reported that I'm on the latest version.
As soon as I uninstalled and reinstalled as stated in your page, the firmware procedure came in. Everything OK in wired mode, I hit the finish and still no light on the mouse, so I guessed I should remove the cable for the wireless update to take place and indeed I was prompted again for an update, but how could I press it when the cursor was dead?? (re-pairing the mouse didn't work) I don't know how many time I tried , I even got a warning message in Korean - don't know what was stated there and too bad I didn't screenshotted it but your engineers might know. Anyway for some reason I managed to complete the firm update on both modes. Don't know though if these are the latest as in wireless mode I get a greyed out message below the version "go in wired mode for firmware update".
**Latest version of Armoury seems way buggy- unlike the previous 2.xx (for me)
Running now
Rog Armoury 1.01.19 (latest)
Spatha wired firm 1.57 (latest)
Spatha's dock (wireless) firm 1.26 (latest) ??

I have a similar issue.

software 3.00.20
firmware 1.72

later software revisions default my firmware to 1.00 . I have reverted back to this as its the only one that allows me to sync with Aura.

my wireless refuses to work, but wired is fine.
when I try and pair, the light flashes green , then as soon as I click the mouse pair button , I get a different colour for a second on the dock then nothing.

please release a version that works, as I have already had to reinstall the OS just to get Aura to work again.

having paid so much for ROG hardware, it is disappointing for this to happen in the first place.

Having read through a lot of threads in the forum, I have concluded the following:

You cannot pair the Spatha with Aura Sync, but should use Armoury to illuminate the mouse.
if you do, other hardware in Aura will cease to sync.

I have read the instructions above, but since I cannot get the Spatha to work wirelessly in the first place,
it would be futile to try it. But I did anyway...and as soon as I rebooted without the Spatha wired. I got what I expected - no updated dock firmware and no working mouse...but to my surprise, when I plugged the Spatha back in again (wired), it too failed to work. I then had to take out the secondary cable that it came with and use a different usb to enable my mouse.

I have given up at this point and resigned myself to the fact that I have paid €154 for a wireless mouse that doesn't work wirelessly.

I have reverted back to the original version of Armoury that was supplied with the mobo and it seems to be stable for the moment. no issues, wireless is working fine.
I am however reluctant to update either the software for Armoury or the firmwares for the dock or mouse.

Here are the versions I found to be stable:

79817

So my spatha is charging when wired , but when i go wireless and i put it on the dock it says its charging but then actually its not charging, soo my dock is not charging my spatha can someone please help me .

It doesnt instill confidence into the brand that this thread has not been further adressed.
My wife bought a Spatha recently and has been very unhappy about the fact that the dock does not work at all. Checked BIOS settings (Mainboard is an TUF GAMING Z490-PLUS (WI-FI)) to ensure power delivery during shutdown, ensured in windows settings that computer goes into restmode only, the dock still does not charge, in any of the USB ports. Tested with other USB devices that the ports are, indeed, powered during shutdown.

Interestingly, dock does charge when connected to my Aorus-board powered rig. It does not work when connected to my wifes Asus-board powered rig.

Mouse has already been RMAd once. At this point, its as good as any cabled 15bucks mouse, and its really disappointing.

Any suggestions to remedy would be appreciated.

Hello
Spatha user here as well. I have been using the mouse on wired mode for the last couple for months due to home office and the mouse not being able to last a day on a single charge.
Now I'm back to the office so I'm using the Spatha only for gaming, the evening/nights, hence shorter sessions, so I'd like to revert back to wireless.

The problem is, the mouse is no longer detected. I have followed the advice given in the sticky post, but it doesn't work. As soon as I go to wireless mode (plugging the dock after unplugging the mouse and turning the switch on), then Armoury says there is no ROG device connected. I tried to press the Pair buttons, no results.
The mouse's LEDs turn on for one or two seconds, then they turn off, end of story. It is as if it was running out of battery (although it is full). If I place the mouse on the dock, then the LEDs are glowing. Wired mode still works fine.
I have reverted back to an early version of Armoury, proceeded with the requested updates, to no avail. Does that mean the battery or the mouse is dead somehow?
I used to use the Spatha with Armoury, or Armoury Crate, it used to work fine, I don't understand what could have caused this. Any help appreciated!

Bahz
Level 12
We're working on the fix for the battery issue, there are still some problems that we need to iron out first so that's why the firmware and software update hasn't been released yet.

bateto_007
Level 7
The problem with wireless connection occurs when synchronous lighting between keyboard and mouse