cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Gladius II - Left & Right Mouse-Click Bug

KeyloggerCat
Level 7
Alrighty ROG'er,
I just bought a Gladius 2 ~1 week ago.
After I installed the Armoury 2 Software, the first I did was doing a Firmware Update with the FW-0186 from the ASUS Site.
Then I noticed that you can do an Update from the Arm2 Software, so it updated to FW-0187.
(Didn't used it between that very much)

While gaming I noticed that sometimes it kinda "holds" my Left or Right Click active till I press that one again.
So i swapped out the switches, but the same still happens.

So that basically means it's a FW or Software issue right, any suggestions?

Sincerely, Tobias
33,524 Views
58 REPLIES 58

MasterC
Community Admin
Community Admin
Does this happen only when you're gaming?
Do the buttons look like they are physically getting stuck down?
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

MasterC@ASUS wrote:
Does this happen only when you're gaming?
Do the buttons look like they are physically getting stuck down?


Same problem here and no its not physically getting stuck down, its like the button go's into to auto shoot in game.
I haven't had a problem browsing the internet pages
[SIGPIC][/SIGPIC]

MasterC@ASUS wrote:
Does this happen only when you're gaming?
Do the buttons look like they are physically getting stuck down?


Hard to tell, in games you get that auto-shoot as some sort of indication.
I'll keep an eye on it while browsing.

EDIT: Not physically stuck

Same with FW-0186 btw

MasterC
Community Admin
Community Admin
Do you both have the Gladius II (not Origin)?
_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

All the described info matches the issue I currently have. Not physical, happened after the firmware update, tried swaping the switches, no MACROS, nothing to do with the game (which is Counter Strike Global Offensive)...tonight I'm gonna try using the other USB cable that came with it, but I doubt I'll have any luck since it is more firmware related-like.

The other thing I'm going to try is to change the button response rate, though I'd hate to lose that low response feature, but just to make sure. I currently use 4ms, gonna try adjusting to higher values.

Hope Asus releases the new firmware with that bug fixed soon.

Alrighty, here's what i tried!

- Using "GladiusII_v0186" (https://www.asus.com/nz/ROG-Republic-Of-Gamers/ROG-Gladius-II/HelpDesk_BIOS/)
& "GladiusII_v0187", which you can only get from the Armoury FW-Updater for some reason.
- Swapping the switches
- Change Button Response Time

What i still want to try:
- Use an older Fw (does a Mod here got one maybe 🙂 ?)
- Task close/Uninstalling the ROG Armoury Software

It's such a nice Mice, the grip, that 3 Buttons and don't forget about that RGB tho.
And since the 3 Mice's i got from oaRrz are all sh*t but just had that nice feelin', i would hate to replace that one here again cause it's perfect.

Just give us another FW fast 😉

MasterC@ASUS wrote:
Do you both have the Gladius II (not Origin)?


Exactly

MasterC@ASUS wrote:
Do you both have the Gladius II (not Origin)?


Yes