Showing results for 
Search instead for 
Did you mean: 

ROG Gladius Core II Software problems.

Level 7
Hi all, i had this mouse since new years, but i allways had problems with it.
I cannot upgrade the software in Armoury crate, i just get a warning sign after the mouse on the update page.
And since i dont use the lastest drivers the app refuse me to change anything, if i could change the ARGB from ICUE, like i can with the Mobo (Strix 550-f) i could live with that, since i don't really want to change anything else. But then again i got into that options page once since i got it so dunno what i can change.

Uninstalling/Reinstalling the app/drivers lead to the same problem, rarely if the lastest patch of Amourycrate installer is uploaded to the product page, the app works until a new patch is dropped. So at best it works for a few weeks.
I had problems with the rest of the updates in Armoury crate in like march, but that solved itself.

No logs to check that i know of, so finding out what really causes the problem is unnecessary hard, all i got is the "You have to update" promt and it seems to install 10-20% then i get the varning sign.

Hi Dallebull85

Welcome to the ROG forum

You'll want to make sure Armoury Crate is updated to version

Try running the update after updating Armoury Crate.

Click the pic to make it bigger.


If this doesn't help...

Did you use the Armoury Crate uninstall tool to uninstall Armoury Crate? You'll want to use the Armoury Crate uninstall tool or it may not fix the problem.

Select your operating system, click "Show all" in blue, it's the third download.

Once uninstalled, Install Armoury Crate version, then go to the Update Center and run all the updates.

Does this get your ROG Gladius II Core updated?

Nope, still doesn't work after complete uninstall/reinstall.

If the driver's from 06/27 (5 days ago) i can't see why Armoury don't realize thats the lastest one.

I don't mind not running the lastest drivers, i do mind that the app blocks the settings if i don't. :mad:
Tried different USB ports as well.

Item Version
---- -------
Armoury Crate UWP App
ROG Live Service
Aura Service (Lighting Service) 3.05.40
Armoury Crate lite service 5.1.4
Aura Wallpaper Service Ej installerad
ASUS AURA Extension Card HAL
ASUS AURA Motherboard HAL
KingstonDram 1.1.12
AURA DRAM Component 1.1.18
Patriot Viper DRAM RGB
Patriot Viper M2 SSD RGB
Universal Holtek RGB DRAM

I would upload my *.logE file but this forum doesn't seem to support ASUS own logs.
*slow clap*
And i can't find a way o open it...

Sorry for the late reply,

There were some more updates for Armoury Crate, try running the update again.

If it's still not updating, I might try uninstalling iCUE and uninstalling your ROG Gladius II Core in Device Manager, check keyboards as it may be listed there too. Once uninstalled, disconnect the mouse, have another mouse on standby to restart or hold the case power button to shut down and restart.

Once booted into windows, connect your mouse then try updating in Armoury Crate again.

Does this get your ROG Gladius II Core updated?

Follow the instructions and post your log in the link below.