Showing results for 
Search instead for 
Did you mean: 

ROG Chakram

Level 8

hi all, I'm having an issue with my ROG Chakram recently after updated Armoury Crate to  It not showing my wireless mouse unless i plug it to the usb c cable provided. i can't setup the mouse via Armoury Crate wirelessly and have to plug in the usb c back again to let the software to control it, example RGB light sync & Auto sleep after idling for 2 minutes....already try fresh install window 11, clean uninstall Armoury Crate few times but the mouse still not showing up unless i connect it to the usb c cable....


Accepted Solutions

Level 8

HI, just want to let you know i reset my PC again by 'Fully Clean The Drive by Cloud Download' and got it fixed. Thank you for  your patience & time for helping me to solve my issue. 

View solution in original post



Hello OreGon

1) With the cable connected, check in Armoury Crate on the Power page that your ROG Chakram is charging.

2) Make sure the wireless dongle is connected to a usb port on your pc.

3) Disconnect the cable.

4) On the bottom of the mouse, set the switch to 2.4GHz wireless mode.

Does this get your ROG Chakram X working wirelessly?

Post me a screenshot of your ROG Chakram Power page.




Level 8

yes, it can work wirelessly but i cant open Armoury Crate ROG Chakram page if the mouse usb C cable is not plug in  and it shows page error (2005) Screenshot 2023-04-28 121052.png

Level 8


Level 8  

If i restart my PC without the usb c connected to the mouse, the battery info icon will not appear on the taskbar tray until i reconnect it back with the usb c cable 

Level 8

without the cable, i cant open the page of ROG Chakram on Armoury Crate, it keeps loading for around 5 minutes until it shows 'page error 2005' message


 Thank you,

So, the issue is with wireless mode.

Some suggestions:

1) Make sure the wireless dongle is connected to a pc usb port.

2) Make sure the switch is set to 2.4GHz wireless mode. (Not Bluetooth)

3) Restart Armoury Crate and check for the 2005 error.

To reset your ROG Chakram:

1) Disconnect the cable from your ROG Chakram.

2) Set the switch on the bottom to wired mode. (Switch set to the center position)

3) Press and hold down left click, right click and scroll click.

4) With all 3 buttons held down, connect the cable.

5) Check Armoury Crate for the 2005 error.

If this didn't help, these errors can sometimes be hard to get rid of. If you can't get rid of the 2005 error, try uninstalling Armoury Crate using the uninstall tool.

In the link below select your operating system, click "show all" in blue, the uninstall tool is the third download.

Armoury Crate - Support (

Once uninstalled, Install Armoury Crate version, then go to the update center and check for updates.

To update your ROG Chakram:

1) Connect the cable to your ROG Chakram and a pc usb port. 

2) Set the switch on the bottom of your ROG Chakram to wired mode.

3) Connect the wireless dongle to a pc usb port.

4) Do the updates in Armoury Crate.

tried all method you recommended, still not working. can't open ROG Chakram page on Armoury Crate without plugging in the usb cable. but its OK, thank for the help, I'll just wait for a new update from Armoury Crate because  the older version from 2022 is working fine until i updated it to the latest version 2023..Thank you


Odd it only happens with wireless mode.

Some other suggestions....

If your ROG Chakram is synced in Aura Sync, try unsyncing it.

Check windows update for any updates.

Uninstall your ROG Chakram from device manager and reboot.

How does device manager look, any yellow triangles?