cancel
Showing results for 
Search instead for 
Did you mean: 

ROG CHACKRAM X troubles with polling rate & lags in use

AlexPaska
Level 9

I bough this mouse and had troubles when set polling rate more than 1000 in many games(some works fine), just low MY FPS, because of moving MOUSE!!!!!!!!!!
I give mouse back and receive new one, now issues just in moving mouse with even 1000 polling rate in radio, cabled! WTF..... Help with that pls, cause when price 150 EURO it isn't OK that i need waste a lot of time on this ... product.

259 Views
15 REPLIES 15

Nate152
Moderator

Is it disconnecting or going to sleep? 

If disconnecting, try the cable with the usb extender connected to a motherboard usb port, it could possibly be a usb port issue.

Is the battery fully charged?

Does setting the sleep timer in Armoury Crate to "Never" help with the disconnecting?

Never.png

 

 

sleep off
batter full
cable with  extender plug in motherboard ROG Z790-E
Disconnect and woun't work, only if change usb. Was in extender, put to pc - ok, 10 minutes, from pc to extender. It is cycled))))

I think, it is a software issue, mb aura, but i try turn off , not help..

Nate152
Moderator

You can try uninstalling Armoury Crate with the uninstall tool and reinstalling.

In the link below select your operating system, click "show all" in blue, the uninstall tool is the third download.

Armoury Crate - Support (asus.com)

Once uninstalled, install Armoury Crate version 3.2.6.1 (first download), then go to the update center and check for updates.

To update in Armoury Crate -

1) Connect the cable to a motherboard usb port, connect the other end to your ROG Chakram X.

2) Set the switch on the bottom of the mouse to wired mode (switch set to the center position).

3) Connect the wireless dongle to a motherboard usb port.

4) Do the updates in Armoury Crate.

Does this fix the disconnecting?

chakram x.png

 

 

Did all of that, has issue on radio still.... Now after reboot it wouldn't work from extender even near by mouse... it's simple not react on radio, but if plug in mother board usb ok with little lags

Be sure you're connecting the wireless dongle to the extender and you're setting the switch to 2.4GHz wireless (not bluetooth).

Try this polling rate test and see how you do.

In wireless mode I'm getting pretty much 1000Hz using the extender.

Mouse polling rate checker | Frequency test | CPS Check (cps-check.com)