Showing results for 
Search instead for 
Did you mean: 

New ROG Spatha Customer - and a very livid one - Armoury caused massive PC Crash

Level 7
I have been eye balling the ROG Spatha for some time. The price on amazon had been $151 forever. I finally found a good deal on it and pulled the trigger disregarding the bevy of software issues I had been reading about. I thought to myself, "surely at this point ASUS - a reputable PC gaming company - would have these issues resolved by now, especially for a mouse that costs that much........ boy was I wrong.

Let's begin. In order to configure your mouse, you must download the Armoury. I understand this. Steel Series and any other well known gaming peripheral company (even the unknowns) have this sort of feature. I found the latest version and installed it. Well, to begin it loaded very very slowly. The dock had already been wired to the computer, but I had never wired the mouse. According to the Armoury, supposedly everything was up to date. I tried configuring the mouse using Profile 1 and for the most part it seemed to work. Except for DPI switching. That didn't work in the slightest. The Armoury gives the impression there are only 2 DPI settings, however, clicking through DPI was never 1 2. It was 1 2 3 4 5 6 7 8 9 then suddenly it changed. Interesting thing, DPI switch would cause the Armoury to close completely. I attempted this several times, was never able to actually set the DPI nor select the correct one. I eventually gave up and got on this forum to discuss the issue. But I see the first post stating that all new ROG Spatha threads/issues should first follow a list of steps. #1 being revert to an older version of Armoury.... here's where the fun beings.

I uninstalled Armoury, followed the provided link, and installed the earlier version. Opened up the app, everything seemed to be in order. The mouse even loaded its profiles. But the program prompted me to update it. So update it I did. However, I noticed that it said the mouse needs to be wired in order to be updated. Remembering what I read about not having the docking station and the mouse wired up at the same time, I unplugged the docking station, plugged in the mouse, and updated Armoury. Supposedly Armoury updated, but stopped working all together. I closed the app and attempted to open it but it would never open. So, I restarted my computer. Upon boot up, Armoury prompts me (again) to update. So I did as told. It updates the program and tells me to restart my computer. Again, I did as told. This time... the computer crashes and restarts. And crashes again.... and again... and again... and again... and again....................... I eventually was forced to wipe the OS and re-image. I AM FURIOUS! I am currently reinstalling my stuff and updating Windows. But GOOD LORD ALMIGHTY! WTF ASUS! I have an ASUS monitor and an ASUS GTX 1070... this experience is leaving me never wanting to ever buy ASUS EVER AGAIN! How on earth is your firmware that bad? How is this mouse this bad? Do you guys do any amount of quality? Oh and fyi, when the mouse was wired, it didn't work. Just thought I should add that.

Anways, I will be saving a copy of this for Amazon and any other website this mouse is sold barring how you (ASUS) reply to this situation. This is borderline a sue-able offense. Had I had some pretty important stuff on my machine (AND I DO - FAMILY PICTURES, ETC - fortunately on a different drive) I would have lost all of that. Just what happened?

Level 7
I had heard support was pretty terrible too. Aight, noted. I will be returning the mouse and rating accordingly.

Community Admin
Community Admin
Sorry to hear about your bad experience with the mouse. I'm inclined to suggest an RMA since it sounds like you may have a faulty mouse. I haven't see any complaints about the DPI switch not working. In case you have opened the Spatha to swap the switches, please check to see if the outer casing is screwed back properly. Does the DPI switch LED turn on and off every time you press it? Perhaps the button is stuck down?
After a fresh Windows install, can you try installing the latest version of Armoury II (2.06.04) directly instead of updating?
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Surely you can understand my hesitation, but I went ahead and reinstalled Armoury...
The software never gets off the ground. Just gets stuck in the 4 dots loading "home screen." As result, it's unusable. Windows eventually comes up with a "software not responding, must be closed." Anyways, without a working program to configure the mouse, the mouse is essentially useless.

Community Admin
Community Admin
So even after a fresh install, Armoury II 2.06.04 couldn't open properly?
Did you pair the mouse and dock? What color is the indicator on the dock?
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

I'll check when I get home. But if I had to guess, 1 of 2 things is happening. Either the software has an issue opening resulting in a frozen loading screen, or the software is waiting for the mouse to respond (which I'm guessing what is what you're thinking based on the question). Again, I'll let you know. For an FYI, this go around I did not connect the docking station but instead connected only the mouse via wire. I was hoping that maybe this would force appropriate firmware onto the mouse.

And I do apologize for my poor consumer attitude. No need for me to be a jerk. Just stressed out. Surely I get a pass after my computer crashed.

I think I may have installed 2.06.01

So the Mouse works and can be moved around on the screen when plugged in via wire. But the Armoury software just sits there and "loads." The mouse itself appears to doing the "breathing" color scheme and the color varies. Mostly blue, though. The software, fyi, eventually crashes and is forced to close.


Community Admin
Community Admin
Your firmware is not up-to-date. I have sent you a link to the latest versions, please check your inbox.
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Level 7
Same issue with DPI switch here. Mouse is maybe a month old and I've been battling it ever since I bought it. At this point I will probably end up returning it and going with something else. For a price tag being asked, this thing works like garbage. A $5 mouse will work better than this. What good are all the "features" when none of them are usable? LOL

Here is how mine works since I bought it (Latest firmware on both Armoury and Firmware, tried earlier Armoury versions too):

- Profile 1 --> Unusable at this point:
Worked initially until I adjusted settings and saved and rebooted. Since then DPI switch requires 15 clicks to turn LED off and go to other setting. During those clicks it will lock mouse to only Y axis, then X axis, then crash Armoury, and cycle through locks until it turns LED off. Sometimes on boot up mouse cursor can't even be moved and I have to plug in other mouse to restore defaults and get mouse working, which still doesn't fix DPI switch issue.

- Profile 2 --> Worked without ANY changes to it until first reboot. After reboot, same DPI switch behavior. Profile is unusable.

Other profiles I didn't use and my feeling is if I use Profile 3 it will get corrupted just like the first 2.

DPI switch press with Armoury crash has this in Event Log:

Application: ROG Armoury.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.FormatException
at System.Number.StringToNumber(System.String, System.Globalization.NumberStyles, NumberBuffer ByRef, System.Globalization.NumberFormatInfo, Boolean)
at System.Number.ParseInt32(System.String, System.Globalization.NumberStyles, System.Globalization.NumberFormatInfo)
at System.Byte.Parse(System.String, System.Globalization.NumberStyles, System.Globalization.NumberFormatInfo)
at System.Convert.ToByte(System.String)
at SPATHALib.Window1.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
at System.Windows.Interop.HwndSource.PublicHooksFilterMessage(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
at MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)
at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)
at MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)
at System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)
at System.Windows.Threading.Dispatcher.PushFrame(System.Windows.Threading.DispatcherFrame)
at System.Windows.Application.RunDispatcher(System.Object)
at System.Windows.Application.RunInternal(System.Windows.Window)
at System.Windows.Application.Run(System.Windows.Window)
at ROG_ARMOURY.App.Main()

Essentially, DPI switch is 15 clicks with LED on to go back to LED off. If counting the initial click to switch DPI, that's 16 clicks. This is not a switch being stuck this is a firmware/software issue. I will make a trip to my local store this weekend and return this overpriced mouse and get 2 Steelseries mice or something. I have done all troubleshooting I can short of wiping my OS and I am not going to wipe and reinstall OS to get a mouse to work. SMH.

I thought ROG Zenith Extreme was plagued with software issues. Now I see that other products are no exemption from poorly written software/firmware.