cancel
Showing results for 
Search instead for 
Did you mean: 

mouse cursor not moving but the clicks are working

spinzo
Level 8

Hi, my ASUS TUF M4 AIR mouse suddenly stopped moving but clicks are working fine, I tried on different PC but no luck !
Mouse firmware version: 1.00.04 latest
please i need help and thank you.

3,179 Views
15 REPLIES 15

Nate152
Moderator

I checked at the ASUS Support Center,  I don't see any firmware updates for the ASUS TUF M4 AIR mouse.

If your mouse is fully updated in Armoury Crate and the sensor is not working on another pc, then it sounds like the sensor has gone faulty.

As a last resort, you could try disconnecting the cable from your mouse and pc and reconnecting it. 

You can also try different usb ports, usb 2.0, usb 3.0.

 

I tried everything, this sensor is broken, so I brought another mouse. thank you for your time

skywalkerx
Level 9

I have the same issue with Asus Chakram X

Nate152
Moderator

Hello skywalkerx

1) Is your ROG Chakram X fully updated in Armoury Crate?

2) Have you tried resetting your ROG Chakram X? (Steps on page 1 of this thread)

3) Have you tried uninstalling your Chakram X from Device Manager and rebooting?

4) Have you tried your ROG Chakram X on another pc?

5) Do you get the same symptom in wired mode and wireless mode?

6) Have you tried cleaning the sensor with a dry q-tip?

Does any of this help?

If you have any questions, feel free to ask.

 

 

 

 

 

Hi Nate,

I have 2 Chakram X which both of them fully upgraded, I tried to reset the firmware with holding mouse buttons and Armoury Crate reinstalled the firmware. The issue happens in both mice only in wired mode and when computer wakes up from sleep. If I disconnect the USB cable and reconnect after the wake up issue will be resolved. While I am not sure if it only happens this way but I feel like it is something related to the polling rate of being set to 2000 Mhz in my case. Because when it is set to 1000 Mhz I feel it rarely happens. I tried to uninstall all mouse drivers using Driver Store Explorer. Armoury Crate installed them back at some point. It is not about the sensor or faulty hardware because I have 2 Chakram X and issue happens in both exactly same way.

skywalkerx
Level 9

skywalkerx_0-1715075456260.png

Above screenshot is when mouse is connected via USB. Below screenshot is when it is connected via wireless dongle.

skywalkerx_1-1715075552269.png