Showing results for 
Search instead for 
Did you mean: 

mouse cursor not moving but the clicks are working

Level 8

Hi, my ASUS TUF M4 AIR mouse suddenly stopped moving but clicks are working fine, I tried on different PC but no luck !
Mouse firmware version: 1.00.04 latest
please i need help and thank you.



Hello spinzo

Try resetting your mouse.

1) Disconnect your mouse from your pc.

2) Press and hold down the Left Click , Right Click and Scroll Click buttons.

3) With the buttons held down, connect your mouse to your pc.

4) Wait 5 seconds then release the buttons.

5) Check Armoury Crate for updates.

Also, check for any debris in the sensor area, I use a dry q-tip to clean the sensor.






I did what you told me to do and i reset the firmware and updated again but unfortunately the cursor still doesn't move and I cleaned it too but no luck and i cant rma I don't know what to do in this case 😞

Can you help me i do everything you said but it still cursor disappear and i see many videos talking about this problem but no way to solve this



In this video, they're showing that uninstalling the HID-compliant mouse fixed the cursor not working.



I've tried this several times and it doesn't work, and when I plug in the mouse I see that the mouse has a HID Keyboard image_2024-03-14_145142464.png


Sorry for a way late reply, have you made any progress?

I'd try uninstalling PS/2 Mouse and PS/2 Keyboard as well, I'm pretty sure you're not using that type of connection.





Well i tried everything i could, Uninstalled the drivers, Disassembly, Cleaned the sensor from the inside, Reset the os, Reinstalled armoury crate, Reinstalled the firmware, No hope this sensor is dead. 
I am afraid that if I buy the same mouse the problem will return.
thank you for your help.

Level 7

I have the same issue 

what is your mouse model?