cancel
Showing results for 
Search instead for 
Did you mean: 

Keris Wireless Aimpoint Losing Connection

leoncon99
Level 8

Since I updated the Firmware of my mouse, I get weird connection issues. The mouse just freezes and is unresponsive for about 10-15 seconds. After that it works like normal. This happens very randomly and is only appearing after the last FW upgrade. Any known issues with the new FW? Is it possible to revert back to the old version? It is really annoying... Tried nearly everything. Reinstall of Armoury Crate, Reinstall FW... I use it in wired mode now and no problem so far. Only happens in 2.4Ghz Mode

8,547 Views
55 REPLIES 55

leoncon99
Level 8

Is Asus reading its own forums? or do we need to report this somewhere else? There is definitely an issue with tihs many people having the same problems

Moffan
Level 8

I'm waiting for new firmware for my Keris Wireless Aimpoint like it's my birthday 😂

Leave77777
Level 8

@asus listen to your users 1 month ago you released a firmware that ruined many people's mouse, you have to take responsibility and solve this problem or at least respond to a message that they are working on it

msponge
Level 8

So I tried using the FirmwareAutoUpdate Tool they sent to update the omni reciever.
now i've got firmware device version 3.00.05 and dongle version 6.00.08 and I have a section in armoury crate that has the omni receiver.

I disconnected my other omni receiver that I was using for my rog falchion keyboard in case that was causing issues. (I am using the keyboard wired now)

THE ISSUE STILL PERSISTS
Fortunately for anyone who has this issue, you can temporarily fix it when ur mouse freezes by switching the switch to bluetooth and then back to wireless.

 

Leave77777
Level 8

I'm going to start placing the return order and everyone should do it since apparently ASUS doesn't mind responding here. This is unacceptable

RSergeyVZ
Level 7

Friends, I have a similar problem.
There were no problems with the previous firmware.
The problem is with the polling frequency.
Test on the website https://benchmarkdb.ru/lab/mouse-rate-checker/
Response: 8.0 ms; Maximum: 128 Hz; This is in 2.4 GHz mode, in USB mode everything is ok! ASUS answer!!!2024-04-14_10-17-30.jpg 

Vampi9
Level 8

I have also noticed my battery depleting way too fast since the last firmware update. I am feed up with this situation. If this is not solved within one more week, I'll start the RMA process

Yes the battery depleting is way too fast for this new firmware update, I dont think RMA will fix this issue, its software issue unless we get a rollback. 

FYI: Using Bluetooth connection, mouse battery drain is way way slower on my gaming.

 

VezTuNdra
Level 8

Hey guys i just purchased the ROG Keris Wireless Aimpoint just 2 days ago. before purchasing i search about possible issues with this mouse and asus rog mouse in general. most problems ive seen are mouses having problems after a firmware update. so heres what i did, I never installed armoury crate  and never updated the mouse's firmware im not having any issues so far. I guess the solution is to never update the mouse firmware

Hello!
Do not update your mouse under any circumstances.
Can you post a screenshot of the firmware version in Armory Crate?
We need to understand the stable version