cancel
Showing results for 
Search instead for 
Did you mean: 

Keris Wireless Aimpoint Losing Connection

leoncon99
Level 8

Since I updated the Firmware of my mouse, I get weird connection issues. The mouse just freezes and is unresponsive for about 10-15 seconds. After that it works like normal. This happens very randomly and is only appearing after the last FW upgrade. Any known issues with the new FW? Is it possible to revert back to the old version? It is really annoying... Tried nearly everything. Reinstall of Armoury Crate, Reinstall FW... I use it in wired mode now and no problem so far. Only happens in 2.4Ghz Mode

1,038 Views
55 REPLIES 55

Vampi9
Level 8

I got exactly the same issue with  my Keris aimpoint  after I updated the firmware through armoury.  It is exceedingly annoying. I hope Asus gets its act together and fixes this issue right away

rainbowkool
Level 7

I have exact same problem after keris aimpoint firmware update to mouse 3.00.05, dongle 6.00.08

There is a lag when moving the cursor. and jumpy as well. before update aimpoint mouse I had no problem.

how can I roll back aimpoint FW?, Do I have to just wait for new FW? 

iicycube
Level 9

Yes recent latest FW update got this problem (device v3.00.05)(Dongle v4.00.01)

The out of sudden disconnected from my mouse really annoying and there is also one more issue is the "high power use" even i set 50% below which made no different.

Moffan
Level 8

i have same issue! asus plz fix this problem

Constant1ne_1
Level 7

Same issue here after the latest firmware update... I also tried manually installing Omni Receiver update from the Asus website but no luck.

toruko61
Level 8

Same problem here. Additionally energy saving and aurasync don't work properly as well. 

Leave77777
Level 8

I have the same problem with my rog keris wireless aimpoint, how is it possible that no one from Asus responds to so many problems with this? 

msponge
Level 8

I also have this issue, i have just tried the firmareautoupdate file they sent, and will update on if it works

 

Didn't help me. I feel like it's the new fw of the mouse itself.

Energy saving and aurasync shouldn't be influenced by the dongle 

Leave77777
Level 8

I have updated the firmware and it does not fix it, I have reinstalled the armory create with the corresponding uninstaller and it does not fix it, the rog keris aimpoint wirelessly stays frozen and only the clocks respond and within seconds it works again, we hope for a quick solution from Asus or Get our money back, this is not a cheap mouse in my country, it's the cheapest.