cancel
Showing results for 
Search instead for 
Did you mean: 

Can't connect ROG HARPE ACE AIMLABS EDITION through the receiver

potqt
Level 7

I got my mouse about a month ago and it's been working perfectly fine until now when i logged on today I couldn't use my mouse wirelessly through my omni-receiver (not connected with armoury crate) i can use the mouse wired and bluetooth but not with the connection
ive tried: reinstalling armoury crate, rebooting my pc, using different usb ports to try my mouse and using the dongle without the usb cord. 
Note: I can't install the drivers as they get stuck at the end when i try to install them
Any solutions?

Screenshot 2024-04-29 204516.png



392 Views
3 REPLIES 3

Nate152
Moderator

Hello potqt

Try installing the firmware update from the ASUS Support Center, then check Armoury Crate. 

Make sure your wireless receiver is connected directly to a pc usb port, it can be a motherboard usb port or a pc case usb port.

https://rog.asus.com/mice-mouse-pads/mice/ambidextrous/rog-harpe-ace-aim-lab-edition-model/helpdesk_...

 

 

 

i tried that but when i click on my omni receiver it says this and when i try to update it nothing comes up except the device firmware and when i try to install it, it says its installed but then it disappears and then comes back and says i need to update it again.

Screenshot 2024-04-30 205002.png

Screenshot 2024-04-30 204804.png

Nate152
Moderator

To update your ROG Harpe Ace Aim Lab Edition in Armoury Crate, follow these steps.

1) Connect the cable to your ROG Harpe Ace mouse and a pc usb port.

2) Set the wireless switch on the bottom of the mouse to wired mode (switch set to the center position).

3) Connect the wireless receiver to a pc usb port.

4) Try the update in Armoury Crate.

You may have to pair your ROG Harpe Ace to the ROG Omni Receiver.

Harpe Ace Omni Receiver.png