cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Gladius ||| Wireless Aimpoint stopped working

Manab1987
Level 7

I bought it 9 months ago and it worked like a charm.

But today I started my laptop and cursor is moving but clicking and scrolling was working only first 5 seconds and then no reactions. If I switch it of and ON it's again works only 5 seconds for clicking and then only moves the cursor.
I tried update it via Armory Crate but no updates found.
Also in Device manages it shows warning for ASUS Component Firmware Update:
This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

How to fix my mouse? Is it possible to redownload drivers?

222 Views
3 REPLIES 3

Nate152
Moderator

Hello Manab1987

Try resetting your ROG Gladius III Wireless Aimpoint.

1) Connect the cable to a pc usb port, let it disconnected from the mouse and have it close by.

2) Press and hold down the Left click, Right click and Scroll click buttons for 5 seconds.

3) With the buttons held down, connect the cable.

4) Check Armoury Crate for an update.

Does this get your ROG Gladuis III Wireless Aimpoint fully working?

 

 

 

 

Thank you for your help.

It helped partially, first 3 points. And via cable it works now as usual.
But I can't see nothing in Armory Crate for an update. And it still shows warning for Asus component firmware Update.
Also if I switch to Bluetooth or 2.4 GHz mode it again stops working.

Nate152
Moderator

Try uninstalling your ROG Gladius III Wireless Aimpoint from device manager, then reboot your pc.

Then check Armoury Crate for an update.