cancel
Showing results for 
Search instead for 
Did you mean: 

Asus rog Gladius vertical bug

costilletax
Level 7
Hi,

I play a lot of cs go and low sens games (400 dpi 1,8 sens in cs go), i Bought this mouse two days ago and i love the shape, i really do, but I've also noticed that the mouse has some click delay and ok, i can live with that i guess
but what i can't live with is this weird bug that happens randomly when moving the mouse vertically(either upwards or downwards).The mouse sometimes draws a straight vertical line, which makes the mouse move like this:
58341

Is there any fix to this? I think it is related to the firmware... If i can't fix it I'll just have to return it
17,540 Views
34 REPLIES 34

costilletax
Level 7
I haven't rma'd mine yet cause i can't find a proper replacement for it(I hate razer with all my heart) so i'm waiting for the new mice to be released, maybe the cougar revenger or even the mouse logitech has been teasing, whatever mouse that has a 3360 and then i'll rma it.

I got my the rog armoury to update my mouse using an older version from the spatha web, it says "1.30" but when i check the info of the mouse in linux for instance it says 1.29.1, so I'm kinda confused, I don't know what the update changed either, i still have the tracking bug
and i tried the replacement 2x omrom switches, one of them was faulty and would actually malfunction if i kept it pressed for 3+ s, the sniper scope would be released without me lifting the finger, and i know is the switch cause i swapped it to the right click and same thing happened. So at this point
I will rma it when i find an alternative, but meanwhile I'd like to know if you are capable of replicating the tracking bug, it happens more often when moving the mouse vertically or in circles and then slowly moving it to one side while keeping the circular motion.

I think it happens when the sensor changes the amount of fps settings it is using, I can get it to malfunction when after moving it quite quickly I try dragging a straight line with it.
Here's a pic of what mousetester displays when the mouse malfunctions:58681


I'm sorry to insist but I truly love this mouse now that i could fix the click delay and if I can find a workaround for this annoying bug before september I'm 100% i won't return it(,I don't care about the faulty switch, they cost 1€ so no big deal) cause other than this tracking bug, it's perfect now.

PD: I forgot actually that I can't plug the mouse to a usb 3.0(they are not intel controllers, they are Etron), maybe it's my mobo or the csm mode enabled, it didn't happen until i updated If i remember correctly.

Hi, this seems to me an issue of something like a tracking glitch. It happens randomly ?

Marco.

costilletax
Level 7
Not random at all, it happens after certain patterns and after hitting a certain speed. It is not related to surface calibration or LOD, I've tested several mousepads so I'm 100% it has to be a firmware issue or just a defective sensor, but I'd like to know which one of those two is the correct answer, cause if it's just my mouse, then i'd get a new gladius.
The higher the polling rate, the easier it is to replicate this. 2000hz + 100hz makes it happen all over the place even when moving the mouse at below 1.x m/s. I guess maybe it's the trick they've used to achieve the emulated 2khz and it's also affecting all the polling steps, but it gets easier to replicate the higher the polling rate you use.

Bahz
Level 12
My guess that it has to be a defective sensor because I'm not able to replicate what you've shown here.

Bahz wrote:
My guess that it has to be a defective sensor because I'm not able to replicate what you've shown here.


I can easily replicate that malfunction. I think all or most ROG Gladius have this problem but people usually just don't notice.

costilletax
Level 7
That's good news then, i've seen some reports with the same problem, so i'm still i bit unsure, have you tried setting it to 2khz with 100 dpi and moving it from one side to the other while circling? It's very noticiable when drawing lines in paint. Thank you again man 😄

Bahz
Level 12
I'm going to try again and see if I can replicate it. This issue has been already reported to our peripherals team but I haven't received any updates from them.

Bahz
Level 12
There's a new version for Gladius which is targeted to fix the click delay issue:
http://dlcdnet.asus.com/pub/ASUS/misc/utils/Armoury_v10119.rar?_ga=1.232537623.963744428.1470027668

Updated today early morning. New firmware report to me version 1.30.3.
Is it correct ?

Thanks.

Marco1971.

Marco1971 wrote:
Updated today early morning. New firmware report to me version 1.30.3.
Is it correct ?

Thanks.

Marco1971.


Yes, should be correct