cancel
Showing results for 
Search instead for 
Did you mean: 

Asus rog Gladius vertical bug

costilletax
Level 7
Hi,

I play a lot of cs go and low sens games (400 dpi 1,8 sens in cs go), i Bought this mouse two days ago and i love the shape, i really do, but I've also noticed that the mouse has some click delay and ok, i can live with that i guess
but what i can't live with is this weird bug that happens randomly when moving the mouse vertically(either upwards or downwards).The mouse sometimes draws a straight vertical line, which makes the mouse move like this:
58341

Is there any fix to this? I think it is related to the firmware... If i can't fix it I'll just have to return it
1,216 Views
34 REPLIES 34

Bahz
Level 12
I also use this mouse for CSGO and I don't have this issue. Did you check to see if you have the latest driver and firmware?

costilletax
Level 7
I do, firmware 1.29 and asus armory 1.27 if I'm not mistaken. Is it possile to roll back the firmware?

I'm not sure if this issue is caused by angle snapping but have you tried disabling angle snapping both in the software and in windows mouse settings? I'll have to check my settings at home to see if mine is enabled or not (currently at work).

Bahz
Level 12
I believe it's not possible to rollback, have you noticed this only since you updated firmware or has it always been like this?

Bahz
Level 12
So I spoke to our peripheral team engineer and he said there's a newer firmware and armoury version that can also fix the click delay, please download the latest armoury and you'll also be prompted to update the firmware.

http://dlcdnet.asus.com/pub/ASUS/mb/accessory/ROG_Spatha/ROG_Armoury_Driver_V2107_Win7-8-8-1-10.zip?...

Let me know if this fixed the issue for you.

costilletax
Level 7
Thank you for taking the time to reply here, but after downloading the software, the firmware is still the same version but at least i can fix the click delay now.

I can't say if this happens after updating the firmware cause the first time i pluggd it I downloaded the rog armoury software so... But I've seen reports of the same problem on overclock.net with this mouse
and they related it to firmware, so I'm pretty sure firmware plays a role in this. I doubt it's the sensor, the Deathadder with the same sensor doesn't have this problem, and the same goes for the evga x5, xm300, etc...

costilletax
Level 7
Ok, i've opened the asus armoury again and a message in chinese prompted and a tick box to disable firmware updates, but i can't update anything.

Bahz
Level 12
Can you share a screenshot of this? I've updated mine yesterday and I believe latest firmware version is 1.33 (?) I'm really starting to think that you have a defective mouse.

costilletax
Level 7
Ofc, here:

58422

And this is what i get when i check the firmware update box
58423

😞