cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate not loading device page for ROG spatha X

Krutanaz
Level 8

Hello, I just purchased a ROG Spatha X and was trying to change the binds on the side buttons. Unfortunately, the device page for it acts as though it isn't connected to the internet and is part of chrome.ARMOURY CRATE 11_21_2023 11_38_57 AM.png

213 Views
1 ACCEPTED SOLUTION

Accepted Solutions

I managed to find a fix on this post here.
https://rog-forum.asus.com/t5/armoury-crate/fix-found-the-system-is-busy-please-wait-for-asus-framew...

I appreciate you taking you're time to offer me assistance. 🙂

View solution in original post

3 REPLIES 3

Krutanaz
Level 8

Also, in the update center, everything is showing as up to date.

Nate152
Moderator

Hello Krutanaz

Have you paired your ROG Spatha X to the wireless charging dock?

Make sure the cable is fully inserted into the dock. On the bottom of the ROG Spatha X, slide the wireless power switch to On, does this give you the buttons page?

You can also try with wired mode.

On the bottom of the ROG Spatha X, slide the wireless power switch to Off, connect the cable to your ROG Spatha X and a pc usb port. Does this give you the buttons page?

There should be two USB-C cables in the box, one for the dock and one to use as wired mode and charging.

 

Spatha X.png

I managed to find a fix on this post here.
https://rog-forum.asus.com/t5/armoury-crate/fix-found-the-system-is-busy-please-wait-for-asus-framew...

I appreciate you taking you're time to offer me assistance. 🙂