Showing results for 
Search instead for 
Did you mean: 

Trouble with GK2000 RGB

Level 7
Hi, i have a trouble with GK2000 RGB. I buy it and using some time without software and was all ok. One day i want to try software but get info if i need upgrade the firmware. So i click ok. After this, first crashed armory crate proces(i was using gladius, and need this software). After this, updater crashed too and keyboard stop working. After restart pc, keyboard working but havent backlight, additional button and volume control dont working too. Support wont help, just say try again. So i trying and trying and getting error on random block. After a few time, program even cant read "Current FW version". My warranty end few month ago. And trying on another pc, on fresh windows, different usb ports. Any version fw updater wont work. I dont see any info if i need to unistall armory crate before update my GK2000. I really need help, beacouse i dont know what now? Anyone can help me please. Sorry for my language. Greatings.

Hi Imc0pl,

Welcome to the ROG forum.

The ROG Horus GK2000 RGB keyboard isn't supported with Armoury Crate/Aura Sync.

Uninstall your current RGB software version and install version 0.97, select your OS, it's the first download.

After installing, try updating the firmware.

Hi and thx for your answer. Maybe my message wasn't enought clear. I already trying all of version of software, 97 too. Support say me if i should be patient and trying to update. But now, after trying many times, the software doesn't recognize the keyboard. Instead of the name, I see the IAP. Previously, after the first failed attempt, the keys worked in addition to m keys, fn, volume and backlight controls. However, after these attempts, some parts do not work or are delayed. When I use capslock on another keyboard, the rog logo lights up, numlock works. The backlight is turned on in a few keys, but only after turning on the pc for literally a moment. The more you try to update, the worse it gets. At the beginning it was still usable somehow, now it is not. I needed ArmoryCrate because I was using a gladius mouse. Not anymore, neither do I have ACrate. It all started with a process crash, armory crate service something, I don't remember exactly. After that, the updater itself stopped responding. An error has occurred and the keyboard is not working since then and the updater cannot read the software version. I have tried on a different pc, clean system and always the same, even worse as I wrote earlier. If I knew armory crate was causing the problem then I wouldn't update and use as before. There is some way to clear the keyboard firmware, or force a clean install. Anything that will help? It's a bit annoying to be left with a broken keyboard that wasn't cheap. The process stopped by itself, I didn't do anything then. I am attaching screens with errors that show up when trying to update, later the program no longer recognizes the keyboard until disconnecting the keyboard or restarting pc.. I would ask for help. Thank you.


To reset your keyboard press and hold the Fn + ESC keys for 10-15 seconds.

Did you use the Uninstall tool to uninstall Armoury Crate? You'll want to use this to remove all services/processes and any corrupted files.

Select your OS then click "See All Downloads", it's the second download.

Try updating your keyboard after using the Armoury Crate uninstall tool.

If this doesn't get it to update, a windows reinstall may be needed.

If you do reinstall windows, update your keyboard first then install Armoury Crate.

Hello, I have already checked the solutions you propose. Unfortunately, no results. Reset does not work, use of the fn key is not detected at all. I'm afraid I need something to flash the firmware, not an updater. Support says the software is not for public use, is there any other option for me to get it? The service will not repair it without a guarantee, even for a fee. I could try to reset via the pcb pin, but I don't know whether to provide ground(-) or voltage(+) there.

Unfortunately, if the software is not for public use, we can't have access to it.

I will suggest to uninstall your keyboard from device manager, restart your pc and let it set up as a new device and try resetting/updating it again.

Its not helping too. Same error. What now?

Sorry to hear, I'm not sure why it doesn't want to update.

I'm pretty much out of suggestions short of reinstalling windows, and even then I can't guarantee 100% this will get it to update, but you could try it as a last resort.

An easy solution would be to get a newer ROG keyboard that is compatible with Armoury Crate, then you can control/update everything from there.

Hello, I have tried to update multiple times but I keep getting the same error. The system is new, I also checked on other pc. Keyboard reset does not work. It's not fair that the keyboard broke due to a bug beyond my control. There is no option to undo this update? Or maybe you know a program that can be used to upload the software? MSI provides such a keyboard program on this microcircuit, why asus not? I tried the reset via the pcb pins, but it also doesn't work. I can see that there is a boot option, so you can upload the software somehow. Maybe some unofficial program, whatever. Maybe something beyond the official distribution channels? The keyboard wasn't cheap and I can't afford to buy something in this class now. Please, have mercy.